Success rate running Windows XP2 ???

Discussion in 'Windows, Linux & Others on the Mac' started by jmv, Aug 19, 2008.

  1. jmv macrumors newbie

    Joined:
    Jul 22, 2008
    #1
    Hi,

    I was curious to find out how many of you have been running Windows XP2 with success!!!
    Has anyone been running without a glich for a while?

    Your input on this would be appreciated cause I am getting very sceptic that I can eventually have a reliable Windows environment on Mac.
    I had been looking at moving to a Mac for a some time and since my Dell XP laptop was due for replacement I thought this was opportunity to get a MacBook have some fun with OSX and still be able to run Windows for my other obligations.

    I never thought that running Windows on my MacBook Pro 17 would give me more problems than running XP on a regular Dell latop. Bad decision???

    My initial BootCamp setup was a nightmare. I eventually got it running after a 2nd repartioning and re-install.

    Since then I have been experimenting for the last month frequent BSOD (Blue Screen of Death) 0x000000b8 (0x00000000,0x00000000,0x00000000,0x00000000).

    At some point I upgraded to SP3 and updated BootCAmp drivers for SP3, same crash behaviour (BSOD).

    Every time it does crash I am doing something different.

    I then tried to VERIFY http://forums.techarena.in/windows-xp-support/78899.htm to pin point the cause of the BSOD. Once done, Windows startups and displays the login or restart dialog and as I click on I get an automatic BSOD:
    Error code 000000c4, parameter1 0000003b, parameter2 00000002, parameter3 8b072fd8, parameter4 00000000.

    Once it reboots after a BSOD, Windows performs a chksdk (which is normal) but although Windows say I can interrupt the chkdsk I have found no key sequence to stop it (ESC, Ctrl-C etc.) The chkdsk takes forever, so I would like to interrupt it if I feel nothing much should be lost or in case I decide to run it manually from a Windows session. Any idea how to interrupt it?

    Also when trying to run in Safe mode it stops at the Mup.sys driver load.
    So there are no way I can diagnose in Safe mode.

    Also I noticed that when my wireless connection drops and attempt a Repair Wireless connectionit freezes Windows systematically. Could this be related to bad BootCamp drivers?

    If there are anyone out there that coulp help before I decide to throw my MacBook Pro out the Window that would be appreciated.

    JM
     
  2. nintendude macrumors 6502

    Joined:
    Jan 17, 2008
    Location:
    MD
    #2
  3. thejadedmonkey macrumors 604

    thejadedmonkey

    Joined:
    May 28, 2005
    Location:
    Pa
    #3
    I'd call Apple, I've been running XP/Vista on and off since the beta was released, and it's never once given me a BSOD.
     
  4. jmv thread starter macrumors newbie

    Joined:
    Jul 22, 2008
    #4
    At some point I did run some test using memtest to see if some bad memory could be the cause. Memtest did reveal some errors to I called Aple, brought the MacBook to an Apple dealer. They spent 2 hours runing test beds and found out no issues. The memtest I was using was reported as nvalid for the MacBook...

    If I call Apple for a Windows BSOD they will send me back to Bill Gates wont they? ;)

    JM
     
  5. Stridder44 macrumors 68040

    Stridder44

    Joined:
    Mar 24, 2003
    Location:
    California
  6. nintendude macrumors 6502

    Joined:
    Jan 17, 2008
    Location:
    MD
    #6
    Yes, Apple doesn't provide support for anything after you are done installing through boot camp
     
  7. neilhart macrumors 6502

    neilhart

    Joined:
    Oct 11, 2007
    Location:
    SF Bay Area - Fremont
    #7
    First of all, XP SP2 is rock solid today. Don't throw rocks, I have XP running for months at a time without any problems (just can not live through power outages) desktop PCs. And I have had no problems with Leopard BootCamp with XP Sp2 on three different SR MBP's.

    I run XP SP2 on my 17" MBP ( BootCamp ) 5 days a week at work with no problems at all.

    So if you are having problems it is either the hardware or you have a corrupted installed system. If you have problems with XP across platforms (your Dell) then you are doing something wrong. Because even though XP is 'old' it is a very sound OS at this time.

    Neil
     
  8. jmv thread starter macrumors newbie

    Joined:
    Jul 22, 2008
    #8
    Hi Neil,

    Thanks for your input. It re-assures me to see how much your XP installations on MAC are stable. I agree, I've been running XP2 on non Mac platforms (Dell) since it was out and had no major issues. As you said it is rock solid.

    However, I've had my share of issues on MAC as described initially.
    When a BSOD happens it is either the hardware or a driver failure.
    In my case I hope (fingers crossed) that is was casused by my graphic driver.
    I did upgrade it last night as per this thread:
    http://forums.macrumors.com/showthread.php?t=547276

    Since then no crash ... time will tell if that was the cause.

    JM
     
  9. Stridder44 macrumors 68040

    Stridder44

    Joined:
    Mar 24, 2003
    Location:
    California
    #9
    MAC? Media Access Control address?
     
  10. jmv thread starter macrumors newbie

    Joined:
    Jul 22, 2008
    #10
  11. jmv thread starter macrumors newbie

    Joined:
    Jul 22, 2008
    #11
    Well the BSOD is back 48 hours after the graphic driver update.
    (Blue Screen of Death) 0x000000b8 (0x00000000,0x00000000,0x00000000,0x00000000).

    I am out of ideas ... any gurus can help here?

    JM
     
  12. goinskiing macrumors 6502a

    goinskiing

    Joined:
    Jun 25, 2008
    Location:
    Meridian, ID
    #12
    I've had Vista (the best Vista install I've had/seen) on it stable since day one and it's been fantastic.

    What version of the bootcamp drivers are you running? Are you using 2.1?

    Also, describe a little more what happened during setup that made things difficult. I am curious.

    I'l do a little more o that BSOD.

    Most BSODs I have dealt with generally have been caused by faulty hardware or faulty user error in setting up hardware.
     
  13. glacies macrumors newbie

    Joined:
    May 10, 2008
    #13
    no problems here

    I've used XP SP2 since the first day of my Macbook. First on Bootcamp and now as a Bootcamp VM under Fusion. Standard installation. Upgraded/updated everything recommended through Bootcamp itself. I run an old Oracle DB server/client on it and sometimes it won't connect to the DB but a restart solves all problems. I don't blame XP there as this sometimes happen with my old Acer as well. It's a rather old program I use (designed for win 98 or NT).

    I've never experienced a BSOD yet (knock on wood there!).

    Minor glitch here and there, especially when I sleep the lappie but everything else is fine.

    Hope you nail the cause of your problem. Try googling the BSOD error code?
     
  14. scotty96LSC macrumors 65816

    scotty96LSC

    Joined:
    Oct 24, 2007
    Location:
    Charlotte, NC
    #14
    I run xp pro via bootcamp and have not had a problem. I need it to run one desktop publishing program from Adobe that is not offered on the mac. Works just fine.
     
  15. jmv thread starter macrumors newbie

    Joined:
    Jul 22, 2008
    #15
    My current BootCamp version 2.1 Build 210A12
    I cannot remember about all the details of my Boot Camp setup but I do remember that when I used the default 32GB partition size that thing went wrong. I did have to specify a little less than 32GB to be able to proceed succesfully with the formating (FAT32).

    I would love to be able to identify the hardware that may cause this BSOD.
    However as I mentioned previously I brought my MBP to an Apple Store who performed all the possible hardware tests which came out negative.

    JM
     
  16. HomeBru Studios macrumors member

    HomeBru Studios

    Joined:
    Jun 4, 2008
    #16
    I have been running XP glitch-free for over a year using Parallels...
     
  17. jmv thread starter macrumors newbie

    Joined:
    Jul 22, 2008
    #17
    Update information.

    I went a little further and downloaded Windows debugging tools.
    http://www.microsoft.com/whdc/devtools/debugging/installx86.mspx#ERB

    WindDbg analysis of the minidump file which was created when the BSOD occured reveals the following. Now I have a better clue that the crash is caused by the driver : applemtm.sys which I assume is part of the the Apples's BootCamp driver.

    Here are the file details:
    File Version: 2.0.1.10
    Description: Apple Multitouch Mouse Driver
    Description: Copyright © 2006-2007 Apple Inc. All Rights Reserved.
    Internal Name: AppleMTM.sys

    Are any of you running a different version?
    I only use the TrackPad and have no external mouse attached.
    So anyone of you who have never encounted a 0xB8 BSOD may be running with a mouse??? I would be curious to find that out.

    Has anyone heard of a problem with this driver?

    JM

    Microsoft (R) Windows Debugger Version 6.9.0003.113 X86
    Copyright (c) Microsoft Corporation. All rights reserved.


    Loading Dump File [C:\WINDOWS\Minidump\Mini082108-01.dmp]
    Mini Kernel Dump File: Only registers and stack trace are available

    Symbol search path is: C:\WINDOWS\Symbols
    Executable search path is:
    Unable to load image \WINDOWS\system32\ntkrnlpa.exe, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for ntkrnlpa.exe
    Windows XP Kernel Version 2600 (Service Pack 3) MP (2 procs) Free x86 compatible
    Product: WinNt
    Kernel base = 0x804d7000 PsLoadedModuleList = 0x8055d720
    Debug session time: Thu Aug 21 16:45:41.327 2008 (GMT-4)
    System Uptime: 0 days 20:52:03.089
    Unable to load image \WINDOWS\system32\ntkrnlpa.exe, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for ntkrnlpa.exe
    Loading Kernel Symbols
    .....................................................................................................................................
    Loading User Symbols
    Loading unloaded module list
    ..................................
    *******************************************************************************
    * *
    * Bugcheck Analysis *
    * *
    *******************************************************************************

    Use !analyze -v to get detailed debugging information.

    BugCheck B8, {0, 0, 0, 0}

    *** WARNING: Unable to verify timestamp for mssmbios.sys
    *** WARNING: Unable to verify timestamp for Wdf01000.sys
    *** ERROR: Module load completed but symbols could not be loaded for Wdf01000.sys
    *** WARNING: Unable to verify timestamp for applemtm.sys
    *** ERROR: Module load completed but symbols could not be loaded for applemtm.sys
    *** WARNING: Unable to verify timestamp for USBPORT.SYS
    Probably caused by : applemtm.sys ( applemtm+53b )

    Followup: MachineOwner
    ---------

    0: kd> !analyze -v
    *******************************************************************************
    * *
    * Bugcheck Analysis *
    * *
    *******************************************************************************

    ATTEMPTED_SWITCH_FROM_DPC (b8)
    A wait operation, attach process, or yield was attempted from a DPC routine.
    This is an illegal operation and the stack track will lead to the offending
    code and original DPC routine.
    Arguments:
    Arg1: 00000000, Original thread which is the cause of the failure
    Arg2: 00000000, New thread
    Arg3: 00000000, Stack address of the original thread
    Arg4: 00000000

    Debugging Details:
    ------------------


    CUSTOMER_CRASH_COUNT: 1

    DEFAULT_BUCKET_ID: DRIVER_FAULT

    BUGCHECK_STR: 0xB8

    LAST_CONTROL_TRANSFER: from 80545c4b to 804f9f0e

    STACK_TEXT:
    f78b2ccc 80545c4b 000000b8 ffffffff 00000202 nt!KeInitializeDpc+0x20
    f78b2d24 f5179569 00000000 00000000 00000000 nt!KdDebuggerDataBlock+0x16b
    WARNING: Stack unwind information not available. Following frames may be wrong.
    f78b2d50 f51bee4a 8a396008 00000000 8a39dfb0 Wdf01000+0x15569
    f78b2d6c f54a153b 8a3960c0 75c6b180 8a394e78 Wdf01000+0x5ae4a
    f78b2d8c f54a1651 75c62210 8a3cfd20 f78b2de8 applemtm+0x53b
    f78b2d9c f51991b2 75cab120 75c0f950 f78b2dc0 applemtm+0x651
    f78b2de8 f5199253 f51caa08 8a3f06a8 8a354ed8 Wdf01000+0x351b2
    f78b2e00 f51705d3 8a3cfe47 8a3f06a8 00000000 Wdf01000+0x35253
    f78b2e1c f517068d 01354ed8 8a2b0210 f78b2e48 Wdf01000+0xc5d3
    f78b2e2c 804f080d 8a3f5020 8a3cfd20 8a354ed8 Wdf01000+0xc68d
    f78b2e48 804f16b0 8a3f5020 8a3cfd20 8a2b0210 nt!IopfCompleteRequest+0x211
    f78b2e78 f6bda0d5 8a3cfd20 898ba1a0 8aa54028 nt!IopCreateSummaryDump+0x18
    f78b2ee0 f6bdad47 8a28a8c0 00000000 8aa547d8 USBPORT!USBPORT_CompleteTransfer+0x373
    f78b2f10 f6bdb944 026e6f44 8aa540e0 8aa540e0 USBPORT!USBPORT_DoneTransfer+0x137
    f78b2f48 f6bdd13a 8aa54028 80546abc 8aa54230 USBPORT!USBPORT_FlushDoneTransferList+0x16c
    f78b2f74 f6beb24b 8aa54028 80546abc 8aa54028 USBPORT!USBPORT_DpcWorker+0x224
    f78b2fb0 f6beb3c2 8aa54028 00000001 8a923bb0 USBPORT!USBPORT_IsrDpcWorker+0x38f
    f78b2fcc 80545e6f 8aa5464c 6b755044 00000000 USBPORT!USBPORT_IsrDpc+0x166
    f78b2fe0 b401ff4a 6803fe95 d007fd2a 00000000 nt!KdComponentTable+0xf7
    f78b2fe4 6803fe95 d007fd2a 00000000 8a923e14 0xb401ff4a
    f78b2fe8 d007fd2a 00000000 8a923e14 805459db 0x6803fe95
    f78b2fec 00000000 8a923e14 805459db b997dbdc 0xd007fd2a


    STACK_COMMAND: kb

    FOLLOWUP_IP:
    applemtm+53b
    f54a153b ?? ???

    SYMBOL_STACK_INDEX: 4

    SYMBOL_NAME: applemtm+53b

    FOLLOWUP_NAME: MachineOwner

    MODULE_NAME: applemtm

    IMAGE_NAME: applemtm.sys

    DEBUG_FLR_IMAGE_TIMESTAMP: 0

    FAILURE_BUCKET_ID: 0xB8_applemtm+53b

    BUCKET_ID: 0xB8_applemtm+53b

    Followup: MachineOwner
    ---------
    0: kd> lmvm applemtm
    start end module name
    f54a1000 f54a4000 applemtm T (no symbols)
    Loaded symbol image file: applemtm.sys
    Image path: \SystemRoot\system32\DRIVERS\applemtm.sys
    Image name: applemtm.sys
    Timestamp: unavailable (00000000)
    CheckSum: 00000000
    ImageSize: 00003000
    Translations: 0000.04b0 0000.04e0 0409.04b0 0409.04e0
     
  18. jmv thread starter macrumors newbie

    Joined:
    Jul 22, 2008

Share This Page