Sudden change of behaviour with dock speakers (Klipsch)

Discussion in 'iPhone Accessories' started by kiranmk2, Sep 22, 2013.

  1. kiranmk2 macrumors 6502a

    kiranmk2

    Joined:
    Oct 4, 2008
    #1
    I've had a set of Klipsch iGroove SXT peakers for a few years now and they have been fine with every iPhone I've owned (3G up to my current 4S)

    For no seemingly detectable reason when the iPhone (now a 4S - which it has been for 10 months) was put into the dock the phone started charging (and the connection sound played) but music continued to come from the phone speaker. After about 1 minute a message popped up stating that the accessory wasn't compatible. After dismissing this message and removing/replugging the phone into the dock it again works perfectly. After upgrading to iOS7 the problem has remained. I have reset the phone and unplugged the speakers with no effect.

    Has anyone come across anything similar or shed any light on what is happening and why it suddenly started after being fine for several years. The fact that it plays perfectly after the message comes up implies it isn't a connection issue.
     
  2. scottbrightman macrumors newbie

    Joined:
    Oct 3, 2013
    #2
    Have similar issue in past but iOS 7 has completely broken it. What used to be a intermittent problem that was always sorted with a quick unplug/replug of my phone has now left my iGroove effectively useless since iOS7 upgrade.

    Anyone has similar issues with docking stations?
     
  3. Legios macrumors regular

    Joined:
    Jan 19, 2012
    #3
    I always get some weird issues when I plug something in while it is currently playing something. I think that the 30 pin has issues converting to other sources if it is playing content thru its speakers. I get not compatible a lot too like this. I just make sure the media is paused and I have hit the power button to ensure the screen is also off and then plug it in. I dont get the errors when I do it in that order.
     
  4. kiranmk2 thread starter macrumors 6502a

    kiranmk2

    Joined:
    Oct 4, 2008
    #4
    I wouldn't mind so much but it used to be perfect! Tested my iPhone in the car dock and it's fine and tested the dock with an old ipod nano and that's fine too so there's something happening between the iOS software and the dock firmware. What really puzzles me is that this happened weeks before iOS7...
     
  5. Black Magic macrumors 68000

    Black Magic

    Joined:
    Sep 30, 2012
    #5
    Is the dock connector going faulty? Have you put the phone on it and push down slightly moving it slowly front and back to see if sound comes out?
     
  6. kiranmk2 thread starter macrumors 6502a

    kiranmk2

    Joined:
    Oct 4, 2008
    #6
    When it's plugged in, the phone immediately starts charging so I know the connection has been made. Moving the phone around makes no difference. After around 45-60 seconds the message about the compatibility issues pops up. After that, unplugging and replugging the phone works everytime so I think it's definitely a software (iOS) issue.

    Were there any iOS6 updates over the Summer?
     
  7. skarey macrumors newbie

    Joined:
    Oct 31, 2013
    #7
    Docking station problems

    Since upgrading to the new ios7 audio is no longer played through my dockings station. The dock recognizes the phone and charges fine, it also recognizes all the play and utility functions, but when the play button is pressed on either the station or on the phone, the music is played through the phone speakers. Still works fine with my iphone 4 which still has the previous operating system. I am not updating that phone, as I am considering going back to it due to the fact that I despise the new system...yep...sounds like progress to me!
     
  8. viewfly, Nov 14, 2013
    Last edited: Nov 14, 2013

    viewfly macrumors 65816

    viewfly

    Joined:
    May 1, 2009
    #8
    Sudden change of behaviour with dock speakers (Klipsch)

    I discovered this same problem. iPhone 5 and ios7. Klipsch Groove.

    I started using the AUX audio jack. Works fine and remote works too.

    However I discovered the fault was the Apple 30pin to Lighting CABLE. I tried two. Both failed to charge and pass audio. It was fine before. An old 4 with iOS 6 still worked.

    So I took my case off and used the Apple 30 pin to Lighting CONNECTOR.

    Everything works fine now!!! Even with 5 and iOS 7.0.3
     

Share This Page