Sudden issue with Boom2 for Mac

Discussion in 'Mac Apps and Mac App Store' started by Tenashus1, Aug 15, 2015.

  1. Tenashus1, Aug 15, 2015
    Last edited: Aug 16, 2015

    Tenashus1 macrumors 6502

    Joined:
    Jul 27, 2011
    #1
    I have a 13" 2015 rMBP with the latest Yosemite update. I have been a Boom and Boom 2 user for a long time with no troubles until yesterday. Repeated uninstalls, and installs, and reboots have done nothing to fix the scratchy, fuzzy, and distorted sound I get whenever I click on any audio source at all. I have to go to "Effects" and fiddle with ambiance and fidelity every time something audio begins. Very frustrating and disappointing, as Boom 2 was working great before.

    Is there anyone on the forum who is using Boom 2 who has encountered this issue? And if so, have you come across a fix? I have downloaded Hear for Mac and that does a great job of enhancing speaker sound on my MBP. But I'd like to have a working Boom 2 as another option too.
     
  2. BoneDaddy Suspended

    BoneDaddy

    Joined:
    Jan 8, 2015
    Location:
    Texas
    #2
    I use it too. I've had periodic issues but nothing a quick force quit didn't fix. I'm interesting in what's causing the problem.
     
  3. Tenashus1 thread starter macrumors 6502

    Joined:
    Jul 27, 2011
    #3
    It started after I updated Silverlight. But, then, when I uninstalled Silverlight, it was still occurring. I don't know. I've emailed Global Delight. Waiting to hear what they say. Boom 2 works fine on my 2012 cMBP, but not on my new Retina. Go figure.
     
  4. Aneef macrumors regular

    Aneef

    Joined:
    Jun 4, 2015
    Location:
    Lahore, Pakistan
    #4
    I am also having some issues with Boom 2. When I plug in my headphones to my rMBP and then unplug it then I can't use the mic anymore. I also tried by going to System Pref > Sound > Input and changed the input source but still no luck. Everytime this happens, my rMBP needs to be restarted for mic to work. Any work around?
     
  5. Tenashus1, Aug 16, 2015
    Last edited: Aug 16, 2015

    Tenashus1 thread starter macrumors 6502

    Joined:
    Jul 27, 2011
    #5
    Fixed. In Audio Midi Setup under Utilities, I changed format value from 96000Hz to 44100Hz, and Boom 2 works like a dream.
     
  6. BoneDaddy Suspended

    BoneDaddy

    Joined:
    Jan 8, 2015
    Location:
    Texas
    #6
    Glad you got it working. I tried "hear" and like it, but find all of it's setting unnecessary, as a producer. Boom is a lot better to me.
     
  7. Tenashus1 thread starter macrumors 6502

    Joined:
    Jul 27, 2011
    #7
    Agreed. Hear is just too complicated. Too much work to get the right sound. Boom 2 is one stop shopping when it comes to sound enhancing for the Mac. Plug and play. Love it.
     

Share This Page