Sudden low fps - Macbook Pro Retina - both in games and cinebench [Solved]

Discussion in 'MacBook Pro' started by Mindtraveller, Sep 23, 2012.

  1. Mindtraveller, Sep 23, 2012
    Last edited: Sep 23, 2012

    Mindtraveller macrumors newbie

    Joined:
    Sep 23, 2012
    #1
    Today I tried to play both BF3 and Assanssin's ceed, but noticed severe lag. Both ran at roughtly half fps, 13-16.

    I tried both updating drivers and restarting several times, with no luck. Then I ran Cinebench, and only got 14-15 fps in the OpenGL test. Normal seems to be about 30. For a while I thought it could be something wrong with Windows 8.

    So I ran Cinebench in OSX - same result. Everything seems to run at about half the fps of what's supposed to be, and has been, normal.

    I haven't played games since the last update from Apple, apart from minecraft, could that update be the problem?

    Any ideas, or anyone with similar problem?

    Base Macbook Retina with 16 gb ram.

    Edit: I suspect the EFI-update this week could have something to do with this...
     
  2. Mindtraveller thread starter macrumors newbie

    Joined:
    Sep 23, 2012
    #2
    Solved it by resetting SMC!

    Read here how to do it, quite far down:

    http://support.apple.com/kb/HT3964

    "
    Shut down the computer.

    Plug in the MagSafe power adapter to a power source, connecting it to the Mac if its not already connected.

    On the built-in keyboard, press the (left side) Shift-Control-Option keys and the power button at the same time.

    Release all the keys and the power button at the same time.
    Press the power button to turn on the computer.

    Note: The LED on the MagSafe power adapter may change states or temporarily turn off when you reset the SMC."
     
  3. blackn macrumors newbie

    Joined:
    Sep 23, 2012
    #3
    I faced the same problem and killed 2 days for playing with system, apps and even was about to re-install the OS X.

    I can only say - damn! this is the untested last update!!!

    Resetting SCM solves the problem! Thank you Mindtraveler - I found this kind of thread via google before downloading the whole OS X installation package.

    How we can Apple inform about this f.....
     
  4. Fabio Pimenta macrumors newbie

    Fabio Pimenta

    Joined:
    Sep 24, 2012
    Location:
    Novo Hamburgo, Brazil
    #4
    Same Issue, Low FPS no Matter I tried

    1st place : Thx a lot. I did a SMC Reset and worked here

    I was really disappointed at Apple cause it's my 3rd Macbook, always paying high prices for a laptop mainly here at Brazil and get this kind of problem ...

    Well, this happend to me since last Friday 21/Sep and I did everything I could, like Reinstall Mac OS X, Install a Clean Windows 7 BootCamp and even at Different OS the same Issue. So I had a bad feeling about Hardware problem or issue ...

    Before Problem my Mac was capable of 30 ~ 40 FPS playing Blizzard Diablo III at High Retina Resolution 2880 x 1800 but after this I was getting 15 ~ 20 FPS at 1280 ish ... So ridiculous :mad:

    Thx again and from now on I won't Install a Apple Update, mainly Firmware ones before I give some days for Public Feedback :cool:
     
  5. whateverandever macrumors 6502a

    Joined:
    Nov 8, 2006
    Location:
    Baltimore
    #5
    Thanks for posting this, came here with the same issue after the EFI update.
     
  6. jterp7 macrumors 6502a

    Joined:
    Oct 26, 2011
    #6
    what's weird for me is that this happened long after the update. I believe it was because I had used the laptop on battery, put it to sleep, then directly plugged into the TB display. The first indication was that the fan was very low the entire time I played...then it was the MBA like jerkiness no matter the resolution. I should note that unchecking or rechecking the menu option for graphics switching did not solve it.
     
  7. mjmiranda macrumors newbie

    Joined:
    Oct 8, 2012
    #7
    Vouch for this! I was getting low FPS thinking that my Nvidia dedicated graphics card isn't switching but after I did this everything magically works! :D
     
  8. NickSoulMusic macrumors newbie

    Joined:
    Jan 19, 2013
    #8
    Mindtraveller, big big big thank you!!! I began to worry about hardware in my macbook, but you save my nerve:) THANK YOU! :)
     

Share This Page