Sudden Mail Password Issue?

Traverse

macrumors 604
Original poster
Mar 11, 2013
6,898
3,136
Here
I am on Mavericks version 10.9.3

I never had any of the mail issues others had because my one school gmail account is used very basic (just inbox and occasional sending). However I just now I went to send an email to my professor and and I get a notice that mail cannot connect to the account and makes me re-enter my email password. I entered it three times and it came back as incorrect all three times.

I gave up and just logged into the web interface to send it, but I don't get this issue. It works fine on iOS, worked fine before, I still receive messages fine on the Mail.app, but it won't let me send. I thought they were suppose to have fixed these issues in a past update :confused:.

I deleted and re-entered the account in settings, but it didn't work.

Any ideas?
 

jlsm511

macrumors 6502
Feb 26, 2008
333
70
KMIA
Are all the server settings correct? I had the same issue and noticed the port it was trying to connect to was wrong.
 

Traverse

macrumors 604
Original poster
Mar 11, 2013
6,898
3,136
Here
Are all the server settings correct? I had the same issue and noticed the port it was trying to connect to was wrong.
I'll double check that, but they should be fine. I haven't messed with its default settings.
 

kave

macrumors regular
Oct 31, 2012
242
68
Sweden
I have seen this occur many times. Mail suddenly claims the password is wrong.
Must be a bug with 10.9.3.
 

jorgk

macrumors member
Mar 20, 2013
99
10
I have seen this occur many times. Mail suddenly claims the password is wrong.
Must be a bug with 10.9.3.
Yes, and in my case the next thing to happen was that Mail usually crashed … it would not matter if I typed the password or refused (choosing 'cancel') - lucky guys you seem to be ;-)
 

Kentuckienne

macrumors regular
Sep 19, 2013
148
7
No>me<where
Took me couple hours to figure this out ... I had set up two-step authentication for some, but not all, of my gmail accounts. What I had to do was go to gmail and have it generate an application specific password for Mail on the Mac, and then put that password into the password field for BOTH smtp and pop servers for each affected account(mail/preferences/accounts). Then those worked. I also put that app-specific password into an account that wasn't using two-step authentication and broke it, but when I went back to the regular password it was fine.

I remember getting a specific error message from Mail that an application-specific password was required ...
 

kave

macrumors regular
Oct 31, 2012
242
68
Sweden
Yes, and in my case the next thing to happen was that Mail usually crashed … it would not matter if I typed the password or refused (choosing 'cancel') - lucky guys you seem to be ;-)
Exactly, always crash after first launch. Same on 10 computers I have updated.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.