Sudden Motion Sensor problems...

Discussion in 'MacBook Pro' started by AnonMac50, Nov 11, 2010.

  1. AnonMac50 macrumors 65816

    Joined:
    Mar 24, 2010
    #1
    Hi. My MBP's Sudden Motion Sensor seems to have gotten busted. I use SeisMac often, and I noticed it wasn't working normally, Same with LiquidMac, Tunnel (an SMS game), and AMSVisualizer. On start up, if I boot verbose, I get
    Code:
    16/8/2008 3:32:03 AM	kernel	SMS::checkForInvalidInts ERROR: we appear to have a hardware malfunction
    16/8/2008 3:32:03 AM	kernel	SMS::setupInts ERROR bad hardware detected, disabling the interrupts
    Also, System Profiler shows its status as disabled, but
    Code:
    $sudo pmset -g
    shows it enabled.

    I'm guessing the SMS is on the logic board? If so, would it be under the 90 day warranty (I had my logic board replaced on September 5 2010)? Thanks.

    PS, ignore the "16/8/2008", as for some reason, my computer does that a for lots of things (eg. iChat messages, Skype messages, System Profiler date/time, Console, etc." The time is correct (its just that Windows messed it up, as both are internet time, and OS X hadn't fixed it yet).
     
  2. giancarlofs macrumors newbie

    Joined:
    Jul 13, 2011
    #2
    I have exactly the same problem you posted. Could you tell me how do you solve it?

    Thanks.
     
  3. AnonMac50 thread starter macrumors 65816

    Joined:
    Mar 24, 2010
    #3
    I took it to the Apple store and they replaced the logic board free (it was within 90 days of the previous replacement).
     

Share This Page