sudden problem with iPhoto library on network drive

Discussion in 'Mac Apps and Mac App Store' started by masteroflondon, Feb 15, 2009.

  1. masteroflondon macrumors regular

    Joined:
    Sep 17, 2007
    Location:
    London, UK
    #1
    I have had my iPhoto library on a USB drive attached to Time Capsule for some time with no problems. I recently upgraded to iPhoto '09, and still had no problems, so not sure that's related. The library updated ok, and I played with Places and indexed some Faces over more than one session, no problems. Upgraded iPhoto on all the macs and tested their access to the library ok.

    Suddenly now, none of the network macs can open the library. iPhoto launches with no pictures visible and has a spinning beechball. I have to Force Quit iPhoto. Same on all macs.

    I then copied the library from the networked drive locally to a mac, and iPhoto could then open it perfectly ok. So I guess the library is not corrupt either.

    Any ideas why this network setup would suddenly stop working?

    Many Thanks
     
  2. masteroflondon thread starter macrumors regular

    Joined:
    Sep 17, 2007
    Location:
    London, UK
    #2
    wow, I'm a lone voice in the wilderness! Shan't take it personally!

    Seem to have resolved this though, so in case anyone comes here with a similar problem in the future...

    I copied the file to my local drive on one mac. It opened from there just fine. So it was not file corruption.

    I then copied it back to the networked drive, and that worked fine from there too! So it's not a drive / network performance issue.

    So my only thought now is there was some sort of performance issue from fragmentation of the library that copying fixed.

    Performance over wifi is still poor, and gigabit is also poor, although less so. iPhoto '08 worked this way and was much quicker.

    If anyone has a better idea on what the problem is, I'd love to hear it. Especially if it can address the remaining performance.
     

Share This Page