Sudden problems with Finder

Discussion in 'OS X Yosemite (10.10)' started by icymountain, Jun 1, 2015.

  1. icymountain macrumors regular

    Joined:
    Dec 12, 2006
    #1
    I have noticed two sudden problems with Finder on my MBP 15" Retina, running OS X 10.10.3 (Yosemite):

    1. When I drag n drop files to move them, the system copies them instead of moving them. Very annoying.

    2. When I move a file to the trash, it does always ask me for my password. Same when I empty the trash. Again, very annoying.

    I ran the disk permissions repair and still encounter these issues...
    Any idea would be welcome!
     
  2. casperes1996 macrumors 65816

    casperes1996

    Joined:
    Jan 26, 2014
    Location:
    Horsens, Denmark
    #2

    There's a setting in Finder's preferences that empties trash securely. It is under advanced. Do you have this enabled?
    Depending on where you move files, it can be expected behaviour. Move a file from let's say Documents to Desktop. Does it still do it? If yes... Hmmm.
     
  3. icymountain thread starter macrumors regular

    Joined:
    Dec 12, 2006
    #3
    After a night and a fresh look at the problem, I found the origin.
    It was (like I was expecting) a permission issue, but not the issue I was expecting. Essentially the directories I was trying to move or remove contained files owned by "root" (!) so my regular account did not have the rights on it. How this happened is probably because they were generated by some file recovery software (I encountered yesterday the first corrupted compact flash card in my life, and rescued the file with a software I never used before, and that seems to be the culprit). Very annoying scenario though.
     
  4. Evren Carven macrumors regular

    Evren Carven

    Joined:
    Dec 16, 2014
    #4
    So, do you mean the files you want to move instead of copying are generated by a file recovery software? How do you solve this problem at last? Thanks for your share.
     
  5. icymountain thread starter macrumors regular

    Joined:
    Dec 12, 2006
    #5
    Indeed, I wanted to move directories containing the recovered files.
    The solution is actually quite simple once the issue is diagnosed: I simply changed the owner of all the files that were owned by "root" to my user account (using command "chown" in the terminal). Then, everything worked.

    The painful part was to understand where the behavior change was coming from (at first, I did even think it was system wide, so I was not suspecting the files themselves).
     

Share This Page