Suddenly cannot delete anything from external hard drive

Discussion in 'Mac Basics and Help' started by videotastic, Apr 5, 2009.

  1. videotastic macrumors newbie

    Joined:
    Mar 29, 2009
    #1
    Hey everyone,

    I have been using a Seagate 1TB external hard drive (Mac OS Extended Format) to archive some of my videos for the past 6 months. I have been using it with no problems whatsoever until now. Today I fired it up and tried to delete a few files from the drive and nothing happens. I drag the files to the trash and hit "Secure Empty Trash" from the finder menu. I hear the "crinkle" sound of the trash emptying, but when I look in the trash the files are still there...it refuses to delete the files.

    None of the files are locked and I have full permissions on both the hard drive and the files. I have never had a problem deleting files until now.

    Any thoughts on what is wrong and how I can fix this?

    Thanks
     
  2. DPA macrumors 65816

    DPA

    #2
    Have you tried repairing permissions via Disk Utility?

    David
     
  3. txnoob macrumors 6502

    Joined:
    Mar 12, 2009
    #3
    What he said.
     
  4. videotastic thread starter macrumors newbie

    Joined:
    Mar 29, 2009
    #4
    I tried doing that, but the option to repair permissions is greyed out. Same when I tried with Disk Warrior.
     
  5. videotastic thread starter macrumors newbie

    Joined:
    Mar 29, 2009
    #5
    Nevermind...I just rebuilt using Disk Warrior and it works again. Not sure what happened, but it's good to go again.

    Thanks for the help.
     

Share This Page