Suddenly can't mount NTFS drives

Discussion in 'Mac Basics and Help' started by Namocol, Apr 1, 2016.

  1. Namocol, Apr 1, 2016
    Last edited: Apr 1, 2016

    Namocol macrumors newbie

    Namocol

    Joined:
    Dec 20, 2015
    #1
    I have an iMac that I use at work for video editing. Some of the disk drives I use are external and formatted as NTFS. At one point or another long time ago this computer had installed both Tuxera NTFS and Paragon NTFS, not sure which one was actually active as it showed both on the preferences, but didn't check because it was working well (if it wasn't broken....)

    Yesterday I was working on the computer when the power went off (we're having energy problems here in Venezuela because of an extended drought), I just turned all the regulators off, unplugged everything just in case and went home. Today I turned on the computer and it can't mount the NTFS drive.

    The drive seems to be ok, I have two of them, both formatted as NTFS, both work perfectly on a windows machine, and neither one mounts in OSX. Some extra info:

    - I've tried uninstalling both tuxera and paragon and reinstalling one at a time, no difference.
    - The drive shows as greyed out in the disk utility (as if it was unmounted). I can verify and repair from there, but shows no errors. If I try to mount it just tells me that i cannot be mounted, to execute first aid and try again.
    - The computer is running OSX 10.9.4
    - Formatting the disk is not an option for the time being.

    Any ideas?... it's kinda urgent, I have some work there that I should be finishing today.

    EDIT: just tried it on another computer, an old macbook running 10.6.8 with tuxera NTFS installed, works without a hitch, but no matter what I do the iMac can't see it. Help?
     
  2. chscag macrumors 68000

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #2
    I'm wondering if you have completely uninstalled Tuxera and Paragon? It's possible that having both of them on the iMac has caused some corruption. It's been my experience especially with Tuxera that it can be unstable and causes problems especially with large NTFS formatted drives. Paragon on the other hand has always worked well. You might want to take a look at uninstall directions for Tuxera and Paragon to make sure that they're both completely removed and that their kexts are not running at start up. Once you've determined the iMac is clean from both programs, install Paragon again and then see if the NTFS drives will mount properly.
     
  3. cruisin macrumors 6502a

    cruisin

    Joined:
    Apr 1, 2014
    Location:
    Canada
    #3
    The installer for Paragon has a uninstaller as well that you can use. Taxer might have something like this as well, but I never used it. After you uninstall both try fixing permissions and reboot.

    If you uninstall both you can still open NTFS drives but not write to them, so you can copy them to your Mac and use them that way. Or put your work files on a USB key using your other computer and work on them that way.
     
  4. Namocol thread starter macrumors newbie

    Namocol

    Joined:
    Dec 20, 2015
    #4
    I managed to finish the job at least by plugging the drives into the macbook and working there (it also has final cut pro), but I still need to solve the problem.

    Today I completely (I think) uninstalled both paragon and tuxera by looking for every file they're supposed to install and anything with their name on it and deleting it, updated to 10.9.5, reinstalled paragon (new version), still no luck.... Any ideas what could be the problem, and how to fix it??.. I'm desperate.
     
  5. richard2 macrumors regular

    richard2

    Joined:
    Oct 21, 2010
    Location:
    England, United Kingdom
    #5
    Please do the following:

    Note: The following procedure must be performed on an OS X user account that has administrative privileges.

    1. Disconnect the external disc from your Mac.
    2. Open Terminal.
    3. Enter the following:

      sudo tail -f /var/log/system.log
    4. Enter your OS X user account password if you're prompted to.
    5. Connect the external disc to your Mac.
    6. Include any relevant messages printed to the Terminal window in a reply to this post.
     
  6. Namocol thread starter macrumors newbie

    Namocol

    Joined:
    Dec 20, 2015
    #6
    This is what shows when I plug the disk:

    Apr 4 08:52:58 iMac-de-elite.local com.apple.kextd[18]: kext com.paragon-software.filesystems.ntfs 100009000 is in exception list, allowing to load

    Apr 4 08:52:58 iMac-de-elite.local com.apple.kextd[18]: Can't load /System/Library/Filesystems/ufsd.fs/ufsd.kext - no code for running kernel's architecture.

    Apr 4 08:52:58 iMac-de-elite.local diskarbitrationd[57]: unable to mount /dev/disk4s1 (status code 0x00000047).
    --- Post Merged, Apr 4, 2016 ---
    SOLVED IT!!!

    Followed Richard2's suggestion with the results I posted, searched on google for "Can't load /System/Library/Filesystems/ufsd.fs/ufsd.kext - no code for running kernel's architecture" and found this thread:

    https://discussions.apple.com/thread/6480918?start=0&tstart=0

    Following nabucodonozor's instructions there solved my problem, it mounted the NTFS drive as soon as I restarted and after installing paragon again I could read and write to it without a problem.

    Thanks everyone for your help.
     
  7. richard2 macrumors regular

    richard2

    Joined:
    Oct 21, 2010
    Location:
    England, United Kingdom
    #7
    Try the following:

    1. Open Terminal.
    2. Enter the following:

      sudo rm -r "/System/Library/Filesystems/ufsd.fs" && sudo kextcache -system-prelinked-kernel && sudo kextcache -system-caches
    3. Enter your OS X user account password if you're prompted to.
    4. Restart your Mac.

    For future reference, you shouldn't install Paragon NTFS and Tuxera NTFS concurrently, and you should regularly update the driver you choose to use.
     

Share This Page