Suddenly my iPhone has decided my WIFI password is incorrect

Discussion in 'iPhone Tips, Help and Troubleshooting' started by jac23, Dec 12, 2010.

  1. jac23 macrumors newbie

    Jun 27, 2010
    I've been connected to my home network since I've had my phone, now out of the blue, my iPhone has decided that my password is incorrect, yet it is correct.

    My connection is fine on all my laptops, so I know it's not a problem with my internet.

    Why has this happened so suddenly and randomly? It just won't accept my correct password. :confused:
  2. mikelegacy macrumors 65816


    Dec 5, 2010
    Pittsburgh, PA
    This has happened to a few people. It's really irritating. The only solutions I would have would be to either restore, or change the password, both of which are really annoying.
  3. Carlanga macrumors 604


    Nov 5, 2009
    reset the network settings on the iPhone and try it after that....
  4. mikelegacy macrumors 65816


    Dec 5, 2010
    Pittsburgh, PA
    Yeah, I suppose you can "Reset Factory Defaults" on the phone.
  5. redwarrior macrumors 603


    Apr 7, 2008
    in the Dawg house
    I restarted my router with no joy. Then I restarted my phone and the problem went away. Hope you get it resolved soon; I know it's frustrating.
  6. Resist macrumors 68030

    Jan 15, 2008
    This happened to me with an iPhone 3G. It took numerous times of inputting the password into the iPhone before it finally worked. Very annoying indeed.
  7. Carlanga macrumors 604


    Nov 5, 2009
    no no no, just reset network settings NOT factory defaults
    you go to General>Reset>Reset Network Settings
  8. applefanDrew macrumors 65816

    Jul 17, 2010
    I just did "forget network" and then re-added it. It's been fine ever since. Try it and see if it works for you.
  9. daniele2610 macrumors newbie

    Jan 4, 2012
    Hi all,

    My iPhone 4 out of blue decided not to accept the wifi password- it says "wrong password for xxx network" - it's my home one it always worked-

    I was away and worked fine for a week in others houses (where the password was stored already) went to other house, tried to connect with passwprd and started saying the pw was wrong - got home last night and didn't connect right away as usual(maybe because I've reset the network when away) so I've put the pw in and again says it's wrong - Of course the password is correct - laptop works fine and iPod touch as well - At work there is a non protected wifi and it connects fine - So looks like the iPhone doesn't accept passwprds for the wifi

    I've tryed to reset the network few times, reboot it few times, reset all settings and update the sofware (version 5.0.1) - nothing worked - aw also unpluged and re-pluged the router at home (knowiing wouldn't' help)

    PLEASE help, very frustrating - I've seen few people had the same issue but nothing worked.

  10. spaghetti head macrumors member

    May 5, 2011
    My home wireless (Netgear WNDR3400) has 2 frequencies, 2.4GHz and 5GHz. My iPhone will only connect to the 2.4GHz, although my wife;s Macbook and iPad will connect to both. My iPhone will occasionally not connect. I go into my wireless router settings and bump the channel one number (it's not set to auto). I find that this makes it so I can connect, and I don't even have to mess with the password or any other settings.
  11. dolampochki macrumors newbie

    Mar 19, 2012
    I had the same problem. I have no idea why this happened, but disabling HTTP proxy worked for my iPhone 3G:

    Go to Settings-->Wi-Fi
    Hit the blue arrow by your network name
    Scroll all the way down to "HTTP Proxy". Your options there are Off, Manual and Auto
    Hit "Off"
    Go back to Wi-Fi Networks
    Choose your network by hitting the network name
    Enter your network key when asked for a password
    Hit ok
    Cross your fingers...
  12. madizm83 macrumors newbie

    Apr 19, 2013
    dont restore if u jailbroken, here is the solution and worked for me

    here is the solution....just for JB iphone 4s
    Iv been searching for a solution myself for more than 24 hours work. Read in a lot of forums and followed everything people say, but it was useless. i lost hope then called apple tech for help and they gave me the same stupid stuff iv been seeing everywhere in internet.

    So, i lost hope and i went to cydia trying to see if there something that maybe by chance may work, finally, i installed "Pushfix" and im connected again to wifi.

    my problem was that i coudn't connect to 2.4 ghz wifi with a password and keeps saying Incorrect Password over and over gain even im sure its correct.

    So give it a shot, install Pushfix and let me know, i believe u can uninstall it after.

  13. Ann P macrumors 68020

    Jun 29, 2009
    I've been having this "bug" ever since 6.1.2, it's incredibly annoying. For the most part, adding the wifi name and password manually works.
  14. madizm83 macrumors newbie

    Apr 19, 2013
    concerning incorrect password

    im happy to hear that it worked for you by doing it manually. in my case, i tried many times to do the same but keeps saying "incorrect password". Didi u have ur Wifi set up without a password? because if it is the case, it worked just fine, till i put password encryption like WPA, WPA2 or WEP, it keeps saying incorrect password in my iphone. the only solution that helped me connect is the Push fix tweak from cydia, it restarted the WIFI logs and push notifications.....
  15. Eddie99 macrumors newbie

    May 31, 2013
    Hi could anybody help every time I try to connect my iphone 5 to wifi it keeps saying incorrect password but its not av tried to reset the network but still no look plz help
  16. MrMacMack macrumors 6502a

    Oct 24, 2012
    Resetting network settings usually fixes this. Some cases when the wi-fi network is a common name such as Linksys can pose problems.
  17. alihasojaso macrumors newbie

    Jul 26, 2013
    concerning incorrect password WiFi

    the best solution is to reset network settings en enter the password for the WiFi before you unlock the sim card. I did it en it works
  18. survnic macrumors newbie


    Dec 12, 2015
    I reset network settings and then hit AUTO. That worked!
  19. LaraStone macrumors newbie


    Sep 29, 2015
    Go to Settings>>General>>Reset>>Reset Network Settings.
    Then try to connect to it.
    OOPs..I just noticed that you already tried this. Have you reset your router yet?
  20. brysrty macrumors newbie


    Jan 22, 2016
    --- Post Merged, Jan 22, 2016 ---
    FANTASTIC. Many Thanks.
    I have had the same problem for 5 days. MOST FRUSTRATING. My proxy was already on OFF, but I touched it anyway and went back and put the password in. WAM-HO.

    Thanks Again
  21. Vorno macrumors newbie

    Apr 10, 2016
    Wow wish that worked for my Ipad2 which is having the same problem.
    Have tried everything in this forum ( and spent an hour on the phone to apple ) but alas - still no go!
    Apple are to get back to me once the 'engineers' have assessed the prob.
    Only thing I haven't tried is the Cydia fix, but $5.99...... :))
  22. AnnGer macrumors newbie

    Nov 2, 2016
    Got mine fixed!!!!!! Go to wifi. Connect to any open wifi. Try this a few times as it wouldn't connect the first time. Then when it connected, I went back to my choice of wifi connection. Type in password and it worked!
  23. graysonbd_jaydengc macrumors newbie


    Nov 22, 2016
    mine still doesnt connect. it just says incorrect username or password. but my password is correct. and my username
  24. mollyperry19 macrumors newbie


    Dec 4, 2016
    --- Post Merged, Dec 4, 2016 ---
    nah that doesn't work, resetting your network setting dont work either
    --- Post Merged, Dec 4, 2016 ---
    --- Post Merged, Dec 4, 2016 ---
    that doesnt work either unfortunately
  25. Rippeddisc macrumors newbie

    Oct 14, 2011
    Same issue. Reset Network Settings. Manually entered SSID. Restarted phone. Etc. No luck...anyone else with an update to this?


Share This Page