Suddenly No Sound On iMac

Discussion in 'iMac' started by BILLDORGAN, May 8, 2013.

  1. BILLDORGAN macrumors newbie

    Joined:
    Dec 15, 2009
    #1
    I am using a 27-inch late 2009 iMAC:

    Processor 2.8 GHz Intel Core i7
    Memory 16 GB 1067 MHz DDR3
    Graphics ATI Radeon HD 4850 512 MB
    Software OS X 10.8.3 (12D78)

    Suddenly, today there is no sound.

    When I click Systems Preferences > Sound > Output there is only one device: Apple TV, Type: Airplay. There should be a device for Internal speakers but it does not appear.

    When I click Systems Preferences > Sound > Input there is no device found.

    When I click Systems Preferences > Sound > Sound Effects all the alert sounds are greyed out.

    I want to hear the sound on my computer.

    How do I get the device in-Built Speakers to appear in Systems Preferences > Sound > Output?
     
  2. Kebabselector macrumors 68030

    Kebabselector

    Joined:
    May 25, 2007
    Location:
    Birmingham, UK
    #2
  3. BILLDORGAN thread starter macrumors newbie

    Joined:
    Dec 15, 2009
    #3
    SOLUTION TO SUDDENLY NO SOUND ON iMAC

    :D

    Here is the solution to my problem:


    Mac desktops (Mac Pro, iMac, Mac mini):

    Shut down your Mac.

    Unplug your Mac's power cord.

    Press and hold the Mac's power button for 15 seconds.

    Release the power button.

    Reconnect your Mac's power cord.

    Wait five seconds.

    Start your Mac by pressing the power button.

    Here is the link:

    http://macs.about.com/od/usingyourm...-System-Management-Controller-On-Your-Mac.htm
     
  4. appelusa macrumors newbie

    appelusa

    Joined:
    Dec 2, 2015
    #4
     
  5. appelusa macrumors newbie

    appelusa

    Joined:
    Dec 2, 2015
    #5
    That totally worked for me! Although all my settings in sound preferences were sorrect, It still didn't play sound from speakers, only headphones. I did as above, turned off computer unplugged 15 seconds, pressed start 15 seconds. Waited and plugged back in. Perfect. Thank you.
     

Share This Page