Suddenly unable to connect to wireless network:

Discussion in 'MacBook Pro' started by Argelius, Jan 20, 2007.

  1. Argelius macrumors 6502


    Jun 16, 2005
    I’ve got an odd problem with my two-week old MacBook Pro and its connection to my wireless network. I’ve done what I think is pretty exhaustive troubleshooting, but remain baffled. Here’s the story.

    This morning I connected to my wireless network (DSL 2WIRE modem/router) with no problem. This afternoon I returned and Airport refused to connect, giving me the error message, “Airport is unable to connect to the wireless network…” The network shows up as being available, but when I attempt to connect, it wont. (I didn’t make any changes or install any programs this morning).

    Here’s what I’ve done:
    [1] Restarted the router
    [2] Repaired permissions
    [3] Deleted the network’s entry in Keychain Access
    [4] Re-entered my WEP code (assuring it is in correctly; I’ve tried both with the “$” and without)
    [5] Used interface robustness and without.
    [6] Attempted to join the network from the System Preferences>Network.Airport route.
    [7] Created a new account and tried connecting.

    Other tidbits of information:
    [1] Another MacBook in the house connects to the network with no problem.
    [2] My MacBook can connect to another (unsecured) network that I can “see” in my house.

    So, it would seem my Airport card is working okay.
    Any ideas??
  2. jsfpa macrumors regular


    Oct 26, 2003
    I would try (if you haven't already) turning off the WEP on your router and see if you can connect.
  3. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia

    This is in reference to the MacBook Pro, right? Have you tried a SMC reset too?
  4. Argelius thread starter macrumors 6502


    Jun 16, 2005
    I hadn't tried that, but I did (I think -- there wasn't any indication that the reset "took"), but alas -- no luck.

    I also tried turning off the WEP code and I can connect.

    I realize that is a "solution" of sorts, but since I share files on my home network, it's not an acceptable one.

    Any other ideas?

    Thanks a ton. Going crazy here...
  5. jsfpa macrumors regular


    Oct 26, 2003
    That says to me the WEB is not set up correctly on the MacBook PRO. I'd look in that area. Probably a stupid question but did you type in a password or ASCII or Hex ?
  6. Argelius thread starter macrumors 6502


    Jun 16, 2005
    I think it was Hex -- I put the $ in front of the number (which is that way I was always able to connect before).

    I found some other posts about MacBooks and 2Wire routers being incompatible. That would be a obvious answer if it weren't for the fact that [1] this same MBP could connect just fine yesterday, and [2] other Macs in the house can connect...

    HEAVY sigh...
  7. Argelius thread starter macrumors 6502


    Jun 16, 2005
    Well, I seemed to have solved my problem. Don't know why it works, but here's what I did:

    [1] Turned off the WEP security in the router
    ====>computer could connect
    [2] Turned it back on
    ====>could not connect (same as original error)
    [3] changed the WEP code to something other than the factory default code.

    Success! Computer connects.

    So, even though I had supposedly cleared the Mac's WEP cache (or whatever it is called via the KeyChain Access).

    Anyway, all is happy now.
  8. Eraserhead macrumors G4


    Nov 3, 2005
    If possible use WPA security on your router, as it is less than totally trivial to hack and has less problems assuming everyone is running Windows XP or Mac OS X.
  9. RedTomato macrumors 68040


    Mar 4, 2005
    .. London ..
    I had a similar problem a while ago. My old iBook would connect no problems, but my new powerbook couldnt connect, despite being 2 feet from the wireless access point.

    Turned out after a lot of headscratching that it was interference from the networks down the road.

    Changing the channel on the wireless access point sorted it all out. (Start with channel 1 and work your way through, don't just try the popular channels 1, 7 and 11).
  10. RedHook macrumors newbie

    Jan 18, 2007
    LA, CA
    I found success like Red Tomato- changing the channel helps, but I still have to do it maybe once a week. My wife's iBook works just fine with the 2WIRE though.
  11. qbmcnabb108 macrumors member


    Dec 9, 2006
    Toms River, NJ
    This just happened to me! I turned my computer off Thursday night with no problems and then I went to use it Friday night, it said it couldn't connect to my wireless network. Going throught the network diagnostics it says that the network requires a password, but there is no password! Ugh, I don't know what to do. Any help?

    ------Got Connected
  12. lauggh macrumors newbie

    Jan 28, 2007
    Los Angeles, CA
    Error connecting to wireless network

    Hi guys. Just did the Software Updates last night and now I can't connect to my wireless. I have a Mac Book, 10.4.8. It's a new one, so this is my first problem since I got it. There are three other computers on m home network, two on wireless and they're connecting fine (someone's even on WoW).

    I've searched around and saw that there's a problem with Airport Extreme... but I don't have that. My router is SBC 2wire. I have WEP encryption, hex, i think. and it's not the default one.

    I'm lost, I don't know what to do. I'm a new Mac user. Be gentle.
    :confused: :confused:
  13. spork183 macrumors 6502a


    Jul 30, 2006
    I have the 2wire also. The first thing to do before anything else, is uplug the power from the 2wire, then plug it back in and let it boot back up. That cures 90% of my odd connection issues with the 2wire. Even when I have computers up on the network, if I have one that can't connect, it usually cures the issue. I don't know why.

    Now that you've already done that, because you, unlike me, read the whole thread...
  14. lauggh macrumors newbie

    Jan 28, 2007
    Los Angeles, CA
    nope, I've tried that many, many times. Didn't work. Somehow I can connect using VPN at school.

    Once, at home, though, AirPort picks up the wireless signal, connects, but can't get online.

    Any ideas?
  15. Dapperdan macrumors newbie

    May 22, 2006
    I'm having the same problem at uni, it picks up the network fine but can only surf the Uni page, not internet for some reason and VPN wont connect!

    I'll investigate more tomorrow!
  16. jimytheassassin macrumors member

    Jan 22, 2007
    Brooklyn, NY
    Same thing has happened to me:

    situation 1 - connected via belkin router ...decided to switch over to airport instead. It requests login (even though it's keychained), but "password incorrect" - BS. Solution, turned off and on the airport card. BINGO.. it works instantly with out need to re-enter the pass.

    situation 2 - tried to switch back to belkin router. It requests login (even though it's keychained), but "password incorrect" - BS again. turned off the airport, and back on.. still doesn't work. opened my browser and requested BINGO it works magically.

    It's definitely a little flakey, but it seems to be a sticky driver issue.
  17. sohon macrumors newbie

    Feb 10, 2007
    ok. well, i must say (with a shame) that i don't know about Macs (i have the MacBook since I really like using iMac at the school), so i have hard time following your suggestions. My problem is very similar to the others'. I got my macbook few months ago, it was communicating with the Internet (router 2WIRE, Gateway) until I installed AirPortExtreme 2007-001. Since then, I've been losing the Internet connection left and right when my computer goes Idle. I've called Mac and ATT several times, and both parties have tried their best to figure out the problem. At the end, Mac person told me that it could be my router and my wireless phone coz they are the same frequency (2.4Hz). When I called 2WIRE, they blamed MacOS X for the trouble. While Im having all of this trouble, my roommate's PC has been communicating with the Internet (and the router) just fine. And that's very frustrating. Can you PLS, PLS, PLS help me??? Im very eager to learn! THANK YOU IN ADVANCE!!!
  18. sohon macrumors newbie

    Feb 10, 2007

    Finally, the problem is gone. It took me a while to figure out what WEP and Wpa meant, but I made it. Swithcing WEP to WPA solved my 'connectin-to-the-Internet' problem, and I'm hoping the network will remain on.
    For those of you who use 2WIRE router, go to, then go to HOME NETWORK->wireless settings->wireless security->change the authentication from WEP to WAP-PSK (i also changed my channel to 11-2.462MHz). Click on custom encrypton key and type your password (w/out $).SAVE.

    Hope that helped!

    P.S. I just want to point out that Apple's customer service is awesome! Among other things, I have found out that Apple's local stores offer various classes for the products.
  19. Yukinara macrumors member

    Jan 26, 2007
    well,until this point,I have seen many people complain about this problem.I have that problem too,and luckily,I managed to solve it without wasting time calling Apple,AT&T,2Wire.......
    My way is............reinstalling everything again.
    Yeah,I know what you're thinking right now, this is not the only way,but I have tried many ways(that included putting the $ in front of the code, change the channel to 7, change password.........) and some people have very limit access to the modem.

    Actually,you don't need to erase everything,just choose Archive and Install.It only take about 1 hour to install and 1 hour to recover your data but then,everything will work fine again.Now,my MacBook work perfectly,not just the AirPort,but EVERYTHING,just like the first time I brought it home.

Share This Page