"sufficient privileges" error when trying to copy over backed up folders

Discussion in 'macOS' started by buckuxc, Feb 27, 2006.

  1. buckuxc macrumors regular

    Aug 28, 2003
    hey all,

    I tried searching for an answer, but I really don't have the time right now to spend 2 hours doing that. I just had my iBook (G4 14") returned to me from repair. It was in 3 times in 3 weeks, but now everything seems to be fine. They had to replace the hard drive, so I backed up 4 folders in the Macintosh HD folder (one level above Users): Applications, Library, System and Users. When I got the computer going today, I thought it would be as simple as copying those folders over and just clicking on "replace". However, when I tried that, the computer told me the operation could not be performed because I did not have "sufficient privileges" to carry it out. I was logged in as an admin and I even tried other methods, including deleting those folders or replacing them one at a time, but with the same result - no "sufficient privileges". What is going on here exactly and how do I go about this now? Thanks.

  2. t0ast macrumors member

    Sep 29, 2004
    Try "Get Info" (command + i) on the backup-folder, click the button left of "details", change the permissions to yourself and press "Apply to enclosed items" if you haven't already.

    EDIT: I might have gotten you wrong: I believe you cannot replace the folders that by standard is in your home directory. You should try putting the contents of the backup folder into the folder in question instead of replacing.
  3. buckuxc thread starter macrumors regular

    Aug 28, 2003
    What about other user folders that I had added on the old machine? And copying over files that I should leave alone vs those that need to be changed. I couldn't make an image of my drive when i was backing up because the drive itself was the problem, so it was flunking the image process.

  4. ElectricSheep macrumors 6502


    Feb 18, 2004
    Wilmington, DE
    Those directories (Applications, System, Library, and Users) are owned by root, and are not group writeable. This means that even if you are designated as an administrator, you cannot replace them. Only root has the power to do that, unless you go ahead and modify their unix permissions.
  5. buckuxc thread starter macrumors regular

    Aug 28, 2003
    Ah, ok well that makes sense now. I'll do a better job of backing up stuff next time. I was able to copy folders within the one set of folder to within the other set of folders, so I think I'm all set. Unless something blows up....

Share This Page