Suitcase and other problems

Discussion in 'Design and Graphics' started by Eggles, Oct 10, 2005.

  1. Eggles macrumors newbie

    Sep 23, 2005
    System specs: 1.8 GHz Power G5, 1GB DDR SDRAM, 149 GB HDD, Adobe CS2 and Suitcase XI

    I am a newcomer to Macs after 15 years of using a PC. But I got a job as a graphic designer at a place where I am the only Mac user and the IT Dept hasn't got a clue about Macs.

    I am having some ongoing problems with Suitcase XI. I have downloaded and installed the Suitcase plug-in recently released along with the update to ID CS2, both of which were supposed to resolve some issues with auto-activation of fonts in ID. Well, sometimes it does and sometimes doesn't. I can live with most of these in ID but I am getting a little frustrated with font problems in other applications.

    After having to launch Word twice today and getting a dozen or so error messages about missing fonts each time, I spent a little time reading the Suitcase Help Manual (large number of pages in PDF format, without links between the index and the page required - useless!!) and could not find any further info on what I now think is a problem with a font set.

    There is a oddly- but distinctly-named 'set' (I think that is the right word) in the fonts list, which when expanded, contains all the fonts about which there are error messages upon launching Word. The set is permamently activated (green dot) as are all the fonts within the set. I also noticed that most/all the fonts in this set (and there are dozens) do not appear to be separately listed in the font list in Suitcase.

    What I was trying to find out today is how to ... I suppose it would be called 'unpack' a Suitcase set. Plenty of info in the PDF about creating a set, nothing on 'uncreating' one. Even when I tried to go backwards and drag a font out from the lower left pane, it would just bounce right back there.

    So how do you get rid of a set but not the fonts it contains in Suitcase? The attached PDF shows the problem.

    Second question... today I noticed that if I used the numbers on the number pad of the keyboard, the application I was using froze and I would have to force quit. I swapped from the standard Apple mouse about a week ago to a two-button scroll mouse, and wondered if this was connected. So I plugged the old mouse back in, and this time, the app didn't freeze, but nothing happened. I couldn't change any numerical values (e.g. bleed margins in ID) but at least I didn't have to force quit. Any suggestions?

    Attached Files:

  2. jtt macrumors regular

    Apr 10, 2005
    Try deleting them from Suitcase then removing the individual fonts from their original folders and re-import them separately. Then....

    ...... Kill Suitcase and get Fontagent Pro. Suitcase and CS2 was freaking killing me for weeks until iDecided enough was enough. It took me about an entire day to reorganize all my fonts, verify, repair, and import them. An extremely long but rewarding task. I have never been happier.
  3. Blue Velvet Moderator emeritus

    Jul 4, 2004
    To remove a set in Suitcase, select it and press the delete key or the backspace key.

    It will then give you an 'are you sure box'. It's that simple -- not seeing the wood for the trees comes to mind here.

    You don't have to 'unpack' the fonts, they'll still be in the database. Look in the window beneath the Sets window, choose all fonts or Suitcase fonts from the pop-up selector and you'll see that they're still there -- you can activate them or delete them individually if you so desire.

    jtt: Although your advice is helpful, many people do not wish to purchase yet another software package to accomplish what should be easy in the first place. We have Suitcase X1 running on all the work Macs and my Mac at home with absolutely no probs except minor quibbles with Pshop which leads me to believe it's a Pshop thing.
  4. jtt macrumors regular

    Apr 10, 2005
    Are you running Tiger and CS2? If you are, you are one of lucky few to accomplish a this bug free feat. Other than Windows, that is the only piece of software that most mass-font mac users complain about. I do know one person who has it running smooth w/ Tiger and a handful of peeps w/ Panther and I LOVED IT under OS9. FAP just plain works.
  5. kgarner macrumors 68000


    Jan 28, 2004
    I'm not a font expert or anything and I haven't used Suitcase, but there is a new program from Linotype called Font Explorer X that is in Final candidates right now. Like I said, I don't know how it compares to Suitcase, but I like it and it might be worth looking into.

  6. Eggles thread starter macrumors newbie

    Sep 23, 2005
    I know it sounds like the obvious thing to do, but what concerned me about deleting the set was (a) I wasn't even sure it WAS a set, since when I selected to 'show all sets', none appeared in the upper window and (b) I didn't know if deleting the set would also delete the fonts from the computer. From your reply, it sounds as though they will still be there.

    So now I know where to start, I will be coming back to ask about the next problem, which is sort of hinted at in the screenshot - and that is of 'fractured' sets. i.e. the components of say, Frutiger, appear to be all over the place and I wondered if it was possible to combine them all into one place. Is this what creating a set called Frutiger would do? Prior to installing the Suitcase update, I followed the advice given on the Extensis website about collecting all fonts as described here:

    I cannot believe fonts can cause so much hassle. I don't have the option of purchasing any other font management software, and if I can't get Suitcase working, I will remove it. I do not need to have a whole heap of active fonts, I don't have to have autoactivation, I don't use a wide range of fonts on a daily basis but just choose two or three for each project, and I am wondering if it is even worth having a font manager.
  7. jtt macrumors regular

    Apr 10, 2005
    Have you checked for duplicates and ran font doctor?
  8. decksnap macrumors 68040


    Apr 11, 2003
    I'm not sure you're talking about a 'set' as Suitcase refers to it. Suitcase sets are like iTunes playlists- groups of aliases of the fonts. If it were a set, it would be in the setlist. I do remember Word installing its own versions of all of its own fonts on my system- really pissed me off at the time- I can't remember what I did about it, besides deleting them all, as I already owned different versions of all those fonts.

    I would take a closer look at how and where your fonts are organized in the finder. This may be where your problem lies, and you may have a bunch of duplicates also. But, I'm no Suitcase expert- I just use it.
  9. Eggles thread starter macrumors newbie

    Sep 23, 2005
    The problem 'set' is marked in the PDF attached in the first post, but it is quite possible it isn't a 'set' - but I don't know what it is. There are no sets listed in the upper window in the lower shot. But the fonts the Degudent 'set' contains number about 100 (common fonts such as Arial and Bauer Bodoni and many others) and these do not appear separately listed in the list of open fonts, even though the 'set' is activated. Hence my concern if I just go ahead and delete the set in Suitcase. Will the fonts it contains still be somewhere? This is a work computer, and I have no idea where the original fonts may be if I 'lose' fonts by deleting the set. I don't even know anyone else who has a Mac if the unthinkable happens.
  10. decksnap macrumors 68040


    Apr 11, 2003
    To see where a font is located on your actual system, click on a font and hit apple+I .
  11. Eggles thread starter macrumors newbie

    Sep 23, 2005
  12. Eggles thread starter macrumors newbie

    Sep 23, 2005
    A bit of a quick update. Someone mentioned Font Doctor in an earlier post and I had no idea what it was until I did some more research and discovered it was a utility packaged with Suitcase. So I ran it - the two stages of diagnosis and organisation took over an hour - and from a total of 2242 fonts examined, 509 problems were found, ranging from missing resources, duplicates, damaged, conflicts, mixed types etc. Now what I need to do is either uninstall Suitcase or delete all the fonts in it, and then reinstall and reload all the fonts that FD put into a folder on my desktop, all nicely sorted alphabetically. And cross my fingers that the font probelms go away.

Share This Page