Summerboard, 1.1.4, no themes in Prefs>Themes

Discussion in 'Jailbreaks and iOS Hacks' started by LookitsPuck, Mar 26, 2008.

  1. LookitsPuck macrumors newbie

    Joined:
    Mar 25, 2008
    #1
    What gives?

    I went through finder, and looked at Library>Summerboard's permissions, and it's set at 420. Isn't this supposed to be 755? Or is there another folder that needs to be such?

    I'm guessing the only reason they're not showing up is because of a permissions issue. Any help would be greatly appreciated!

    BTW, 1.1.4, T-Mobile, used iPlus to jailbreak/unlock/activate.

    Cheers!
     
  2. LookitsPuck thread starter macrumors newbie

    Joined:
    Mar 25, 2008
    #2
    I'm not sure if this helps or not, but when clicking on Themes, not even my current one (which is the stock theme) shows up. Anyone know if this is permission based or not? Do I need to SFTP into the device, and chmod them to 755?
     
  3. darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
    #3
    Folders are 755, PNGs are 644 (although they can be 755 as well).
     
  4. LookitsPuck thread starter macrumors newbie

    Joined:
    Mar 25, 2008
    #4
    Interesting. Everything is set as such. But I have nothing listed under Themes.

    Anyone know what's up?
     
  5. joshellis625 macrumors 6502

    joshellis625

    Joined:
    Feb 16, 2008
    Location:
    Baltimore
    #5
    Themes have to be in /var/mobile/Library/SummberBoard/Themes

    That happens to me.... Installer will put them in /var/root/Library....

    then I have to move them myself.
     
  6. LookitsPuck thread starter macrumors newbie

    Joined:
    Mar 25, 2008
    #6
    They're actually there. :(
     
  7. LookitsPuck thread starter macrumors newbie

    Joined:
    Mar 25, 2008
    #7
    Oh, hell yeah. After numerous uninstallations, and installations of SB, the fixes, etc. I realized that the SummerBoard folder itself, through SSH, was only 644 not 755, but everything underneath it was proper.

    Now we're working!
     
  8. ndebonfilhs macrumors newbie

    Joined:
    Apr 3, 2008
    #8


    how did u change from 644 to 755 through ssh
     
  9. laz305 macrumors regular

    Joined:
    Jul 24, 2007
    Location:
    Miami
    #9
    hopeless for me, I tried everything and nothing works. awesome Installer it's useless to me.
     
  10. LookitsPuck thread starter macrumors newbie

    Joined:
    Mar 25, 2008
    #10
    Download WinSCP. It's free.

    Get your IP of your iPhone by going to Settings>WiFi>Networking You're Connected To.

    Open up WinSCP. Put in the IP address. Username is root. Password is alpine on iPhones versions 1.1.1 and up. Before that I think it was dottie.

    Then just navigate through the hierarchy. Find the folder, right click on, and change the appropriate permissions.

    Another app that comes in handy is iPhoneBrowser. Don't have to worry about loging in and all that crap. It's a very handy app.

    http://code.google.com/p/iphonebrowser/
     
  11. perm macrumors newbie

    Joined:
    Apr 14, 2008
    #11
    I'm still lost I d/l cyberduck but I saw that my themes were in the right folder but I could not or did not know how to change the Numbers to 755.

    Right now if I install a theme It will not show up in summerboard->themes
     
  12. igotgame1075 macrumors member

    igotgame1075

    Joined:
    Dec 10, 2005
    #12
    My problem is when I SSH themes onto my phone, they won't show up in Installer to uninstall them. I have to delete them through SFTP with WinSCP. Are themes manually added onto the phone ever supposed to be visible under the uninstall option in Installer?
     
  13. pucku19 macrumors newbie

    Joined:
    May 1, 2008
    #13
    :confused:
    First off, nice name :)

    Secondly, my iphone came to my unlocked already with installer on there, BUT it doesn't have jailbreak...do I still need to install jailbreak?

    I tried logging into my iPhone using root and alpine, but it doesn't work.

    I also tried iPhoneBrowser, but I don't see how to alter permissions using this program.

    My phone is 1.1.4 and I'm on a PC.

    Thanks in advance!
     

Share This Page