Super Bizarre Lost Right-Click in OSX 10.6.8 SnowLeopard!

Discussion in 'Mac Basics and Help' started by OldCorpse, May 8, 2013.

  1. OldCorpse macrumors 65816


    Dec 7, 2005
    compost heap
    I'm on a late 2009 i7 2.8Ghz iMac, OSX 10.6.8, Magic Mouse (also Mighty Mouse). All updates installed.

    Today, randomly in the middle of the day, while using my computer, I lost the ability to use the right click on my Magic Mouse. I also tried the wired Mighty Mouse - same result, no right click

    BUT it is not a total loss - it is selective. For example, I have the right-click on the desktop, in iTunes, in other programs. But I don't have it if I try to right-click on a folder inside Finder, or any files in a folder, doesn't matter what the file is: jpg, epub, flv, whatever. Now, like I said, if I open Finder and try to right click on any folder, I can't. BUT I can right-click on folders that are on the desktop!!! So, since I wanted color labels on some folders, what I have to do is drag them from finder onto the desktop and there I get my right-click back and now I can color code them.

    Here is what I have done so far:

    1)repaired permissions

    2)restarted the computer

    3)repaired permissions again

    4)tried to switch off Magic Mouse, then switch on

    5)tried my wired Mighty Mouse

    6)gone into Settings menu for Magic Mouse and toggled on and off the Secondary Click from Right to Left and back again.

    No joy. I still don't have my right click in bizarre ways.

  2. bobsbarricades, May 10, 2013
    Last edited: May 10, 2013

    bobsbarricades macrumors regular

    Feb 4, 2007
    OK, this is strange but almost the same day you had your problem I now have mine. Macbook Pro 3,1 with Magic Mouse but I can't right click in finder using my mouse or trackpad. Can't control click with either either.

    Please help someone

    [edit] - I booted into safe mode (hold shift after you hear the ding and release after the progress bar shows up) and that fixed it! good luck!
  3. OldCorpse thread starter macrumors 65816


    Dec 7, 2005
    compost heap
    Thanks, bobsbarricades, I guess I'll try booting into Safe mode - just doing that by itself fixed it? Right now I'm doing a lot of stuff, but once I'm done, I'll do the safe mode thing in a couple of days.

    Strange that nobody else has come across this issue. Btw., the same issue happens on external drives - no right click on folders/files there.
  4. mirageglobe macrumors newbie

    May 15, 2013
    Strange thing happened to me too

    This happened to me too.

    Did the safe mode boot and worked good after another reboot.
    Google Drive killed itself when i rebooted so it might have been updates to Google apps/products?

    anyway. thanks +1
  5. infimo macrumors newbie

    May 15, 2013
    Same here!!

    Same here...

    iI'm on iMac i5, 2,5GHz, 4Gb RAM, OSX 10.6.8 .

    No right click nor ctrl click on folders and files besides the ones on desktop and side bar folders.

    This issue started this month? All the posts are from May 2013...

    Already tried another mouse and nothing happened.

    Again: Anyone has a clue?!
  6. JoannaPoe macrumors newbie

    May 16, 2013
    The same thing happened to me earlier this week. I'd be suspicious of Google, because at the same time I lost the ability to print from Chrome to one of my Xerox machines (it asks for resources that are TOTALLY there, like 8.5x11 paper).

    I've tried normal restarts, but I'll try the safe-mode after work today and post again.
  7. JoannaPoe macrumors newbie

    May 16, 2013
    Safe mode fixed it

    That absolutely fixed it, and now I can right-click in Finder windows again. My Google-drive also crashed on reboot after a trip through safe mode, so that only makes me more suspicious.
  8. C4qzlt6n macrumors newbie

    May 17, 2013
    Safe mode fixed for me as well

    Thanks so much to all for this fix. Same right-click issue as described. I tried several different mice, lots of searching on "right click" issues but nothing worked. Today I find this post and it works perfectly.
    Strangely right-click was working on other accounts but not on mine. After safe mode reboot, Google Drive also crashed as well, so I also suspect there was something there with GD.
    Once again thank you for the great help.
  9. OldCorpse thread starter macrumors 65816


    Dec 7, 2005
    compost heap
    And finally I too can report on this. Yes, safe mode cleared it up, and yes, google drive crashed upon normal re-boot.

    So, resolved. But interesting, that for all of us, the google drive crashed!

    Thank you to bobsbarricades for finding the solution.
  10. VitaminD5 macrumors newbie

    May 21, 2013
    Same problem and now it's back!

    Hi everyone,

    I've had this same problem for a while now and have wondered why. I booted into Safe Mode and the problem was no more - I could right-click again.

    Then I restarted normally and instead of Google Drive crashing (it didn't), all my finder windows appeared and then they went away - probably my finder crashed. I brought up a finder window and I could right click during this session, but I thought I'd better restart one more time, and...

    The problem is back! All my finder windows are all closed, too, so oh well I lost 'em. Not a big deal.

    But what is going on with this right-click issue???

    I'm going to restart into safe mode and then restart normally and see if that works again, and this time I'll stop there, but just fyi to all experiencing this - it may be back upon another restart.

    If anyone finds the culprit - let's get 'em! :cool:
  11. OldCorpse thread starter macrumors 65816


    Dec 7, 2005
    compost heap
    An Update: after every re-boot, the google drive would have a problem and have to be shut down. Then yesterday, it didn't show a problem and wasn't shut down. Only now my finder started crashing, but very strangely - only briefly, before it would come up again, but this would happen over and over again every minute or so - all icons would disappear for a second and then be back. I ignored the problem, but today I was copying something from one folder to another and the finder crashed in the middle of the operation and the copy was not successful. Clearly that was a major problem.

    So, I've quit google drive from the menu bar, and so far the finder has not crashed again. We'll see. I think there's clearly some kind of incompatibility between Snow Leopard 10.6.8 and google drive.
  12. VitaminD5 macrumors newbie

    May 21, 2013

    I haven't had a problem with Google Drive that I've noticed. I did experience the finder crash and none of my Finder Windows came back - this has happened twice.

    The pattern for me is this:
    1. Boot to Safe Mode (to fix the right-click issue)
    2. Reboot normally - finder crashes and I lose all Finder Windows - but I can right-click.
    3. If I ever need to reboot again, I may lose the ability to right-click.
    4. Repeat when necessary.

    The app that keeps crashing lately is CrashPlan. It's crashed over and over again. They're working on a native app that should solve the issue but it's memory related.

    Anyone else using CrashPlan?
  13. judyutah, Aug 30, 2013
    Last edited: Aug 30, 2013

    judyutah macrumors newbie

    Aug 30, 2013
    Mouse problems OS X 10.6.8 Right AND Left Click

    Been having mouse problems with my mac OS X 10.6.8 for several weeks. Tried different mouse(s)... not that. With mine, it will not LEFT click on anything....and RIGHT click I can highlight things I click on but do nothing... so both clicks don't really work. Read this forum and tried the SAFE BOOT yesterday.... never knew about it before.... then all my icons appeared smaller on my desktop and I lost the little airport icon... could not go online at all... so called AT&T tech support (for Uverse in my case)... and techy said to do restart.... did that and voila! The icons went back to their regular (larger) size... and I was able to go online no problem... go to any site, etc. So I got my online 'fix' and work done.... then shut down (BIG MISTAKE!) Tried going back online, regular way.... NOPE. Problem was back. So unplugged it to shut it off (since I could not use my mouse to select anything.... and tried the SAFE BOOT again, but this time, NOTHING.... didn't work at all.... So I'm stuck using a very old Mac OS X 10.4.11 just to get online. Seems funny many of you are posting this around the same time.... I wonder if it's google drive, as one of you mentioned, and the OS X 10.6.8 version? Any ideas? I'm probably going to have to break down and get the tech in my town to come by. Please send ideas if any of you know a solution! THX, Judy Utah
  14. opensesame macrumors newbie

    Jun 12, 2014
    Reset PRam

    Shut your computer down. Start up again holding the alt, cmd, P & R keys. Wait for the second chime sound, let go of the keys and let the computer start up normally.

Share This Page