Super Drive and New Drive not showing up

Discussion in 'Mac Basics and Help' started by Freis968, Mar 6, 2009.

  1. Freis968 macrumors 6502a

    Freis968

    Joined:
    Mar 1, 2007
    Location:
    Winter Park, Florida
    #1
    I just installed a new Samsung Lightscribe drive from OWC and now neither my Super Drive nor the new drive shows up. When I check my Sys Profile under Disc Burning this is what is showing up....

    No burning device was found. If you are using an external device please make sure that it is connected and powered properly.
     
  2. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #2
    Did you set the jumpers on the back of your new drive to the Cable Select position (or the Slave position if your original drive is set to Master-- I have seen both versions of jumpers on various Mac Pros)?

    A conflict of that type can indeed cause neither to be seen by the system.

    In other words:
    If your original SuperDrive was set to CS, then the new one should be too.
    If your original SuperDrive was set to Master, the new should be set to Slave.
     
  3. Freis968 thread starter macrumors 6502a

    Freis968

    Joined:
    Mar 1, 2007
    Location:
    Winter Park, Florida
    #3
    Yes, it was the jumpers. I had to literally "rip" off the front disc door to get the drive to pop through the slot in the Mac, but I guess I was too rough because now the door won't open to get the drive tray out of the Mac...man between this and that new graphic card I put in tonight, I have just about wanted to pull my friggin' hair out!!!:eek:
     
  4. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #4
    That is a shame- when I bought a couple of Pioneer drives OWC sent a sheet covering removing the front bezel from the drawer on the drives. I'm surprised they didn't for you drive since none will work without removing it!:( Good luck-- and if by chance you are talking about the aluminum door on the MP not opening, there is a tension adjusting screw inside that can be backed off about 1/8th of a turn to make it easier for the door to open. I remember reading about that in another thread quite a while back but didn't need to adjust it in mine. Well at least the drives are working- that's a start.
     
  5. Freis968 thread starter macrumors 6502a

    Freis968

    Joined:
    Mar 1, 2007
    Location:
    Winter Park, Florida
    #5
    I guess I ruined the drive ripping the door off...DAMN!!!

    It just will not even try to pop its head out of the Mac...:mad:

    I guess I will just take the drive to the gun range, pull out a shotgun and blast my frustrations out!!!

    Thanks for the assistance all.
     

Share This Page