Super Duper Stuck Cd

Discussion in 'MacBook Pro' started by 16bitbrain, Dec 23, 2008.

  1. 16bitbrain macrumors newbie

    Joined:
    Dec 23, 2008
    #1
    I just recently replaced my dead HD on my 12 inch G4 1.33. After reassembly and formating i came upon a new problem. I cannot eject my restore disk. The CD seems to eject (icon disappearing) but is impeded from fully coming out. the CD then reboots. I have tried all the usual techniques, including booting Firmware. Anyone have any suggestions, perhaps i could have somehow tweaked the disk drive during reassembly? appreciate any help.
     
  2. donbenjy macrumors 6502

    Joined:
    Oct 15, 2008
    #2
    If you replaced the HD, then obviously you're ok with opening it up, and I assume you tried holding the mouse button on startup anyway, then I reckon the best bet is to open it and try to fix the problem mechanically, as that's what it sounds like...

    Maybe you nudged the drive or something is impeding the ejection of the disc - I'd try either A: removing the drive physically from the machine, and booting with it out of the enclosure - then you can tell if it's the actual drive, or something in the case construction.
    B: disconnect the drive and boot up (not sure what'll happen, but hopefully it should just boot!)
     
  3. areusche macrumors regular

    areusche

    Joined:
    Jun 24, 2008
    #3
    Try this,

    Take a plastic card like a credit card or driver's license and power down your computer. Stick the card in the drive slot and power up the machine. You might have to fiddle around for a bit but try to put a little pressure down on the card so it'll push the disc inside the drive upward. You'll definitely hear the CD start to spin up but the drive will fail to read the disc and spit it back out.

    I've had this happen to me once and I read this tip from Apple's support forum.
     
  4. 16bitbrain thread starter macrumors newbie

    Joined:
    Dec 23, 2008
    #4
    Thanks for the input guys.

    I have tried fiddling with a credit card, but not in the manner you suggested, i'll have to give it a try. Ultimately i may just have to re-open the system and manually remove the CD. At least this will afford me the opportunity to figure where the one remaining screw belongs
     

Share This Page