Super Slow Wireless with New Router

Discussion in 'MacBook Pro' started by kevo0822, Jul 9, 2008.

  1. kevo0822 macrumors regular

    Joined:
    Jul 13, 2007
    Location:
    New England
    #1
    So I recently bought a Linksys WRT160N to replace an old router in my house. The network worked fine with the old router before it died... Browsing speed was great, download speed was great. Now that I have the WRT160N however, my network speeds have plummeted. And it's JUST my MBP... the rest of the computers in my house are Windows PCs and they are surfing away at supersonic speeds compared to what I'm getting on my MBP.

    At first I thought it may be the wireless security (WPA) so changed it to WEP... no change. So then I just disabled it altogether... no change.

    The Windows PCs are getting speed of about 2000 Kbps whereas I'm getting between 150 and 500 Kbps. I've already replaced the router once...

    Is there anything I can do, or is this router just not going to play nice with Mac?

    BTW- I have a 2.2 SR MBP
     
  2. lewisekrantz macrumors newbie

    Joined:
    Jul 4, 2007
    #2
    Try Changing Channels

    Have you tried changing the channels on the router ?
     
  3. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #3
    I've had problems with a Linksys on my MBP and I updated the firmware to DD-WRT and it worked like a charm.
     
  4. kevo0822 thread starter macrumors regular

    Joined:
    Jul 13, 2007
    Location:
    New England
    #4
    I eventually didn't know what else to do so I called Applecare... in the end, he told me to clear Safari's cache. My speeds are back to normal now. Weird... I didn't know having a full cache could slow things down like that...
     
  5. nyzballa12 macrumors member

    Joined:
    Nov 5, 2006
    #5
    Try playing around with the configuration in the router menu. Also, try connecting via an ethernet cable to see if it is the laptop.
     
  6. khf525 macrumors newbie

    Joined:
    Jul 14, 2008
    #6
    A little extra help

    I had the same problem with my macbook being slower compared to the PC's in my house while using the linksys wrt160n router. I finally solved the issue by going to basic wireless settings and changing it to manual. Once changed to manual I changed the network mode to BG-mixed. This repaired my slow connection. My bandwidth went from 500 kb to almost 5 mb. I guess the current airport software has a problem with the 802.11 N stuff.
     
  7. Adamy macrumors newbie

    Joined:
    Feb 24, 2010
    #7
    Slow connection

    I have the same problem, but not sure how to change the settings you guys explained. Do I change the setting on my router or Powerbook? Please explain. Thank you.
     

Share This Page