Super weird optical drive issue

Discussion in 'Mac Pro' started by rdsii64, Jan 1, 2015.

  1. rdsii64 macrumors regular

    Joined:
    May 14, 2008
    #1
    My 3.1 mac pro has continued to soldier on with narry a problem until recently. The optical drives in my machine are starting to behave in a wierd way. What happens that when ever the drive is empty, I have to press the eject key multiple times to get the drive to open. Now it gets even weirder. When ever there is a disc in the drive, the button always works first time like it should. At first I thought it was simply a bad drive, but both optical drives do this and they started doing it at the same time. One drive is the stock super drive it shipped with, the second drive is an LG bluray drive.

    Other than taking multiple attempts to open an empty drive, both drives function as they should. They read from and write to any compaltible disc.
     
  2. Loa macrumors 65816

    Loa

    Joined:
    May 5, 2003
    Location:
    Québec
    #2
    Hello,

    First, check the cables, make sure they're securely attached. Seems stupid, but I solved one optical drive this way.

    Second, does the problem exist for all users? Even new users? Have you tried root user?

    Third, try booting from the recovery partition and see if it works.

    Loa
     

Share This Page