SuperDrive and 3rd party Blu-ray burner not working since 10.9

Discussion in 'Mac Accessories' started by gtackett, Dec 10, 2013.

  1. gtackett macrumors newbie

    Joined:
    May 19, 2011
    Location:
    USA
    #1
    I have an Early 2009 (Mac 4,1) Mac Pro. It has the factory-installed Superdrive as well as an internally installed third party Blu-ray burner. I bought this system used several months ago. It was running 10.8.5. I had used the Superdrive to read successfully, but I hadn't tried burning on it. I had never tried the Blu-ray burner, though (of course) I had the original owner's assurance that it was working (whatever that may be worth).

    I updated my OS to 10.9 shortly after it went public a few weeks ago. At this time it had been at least a week or two since I had used the Superdrive.

    A few days after installing 10.9 I had burned a DVD on my PC and carried it to the Mac Pro to transfer some files.

    Well, the Superdrive spun the DVD a bit and made the usual sounds, then ejected the tray (no error messages). After trying two or three more times with the same results, I decided to try using the Blu-ray burner to read the DVD.

    Well, I can't read it using the Blu-ray drive either. It behaves just like the Superdrive, except the drive tray didn't auto-eject. Once it's loaded, there's no indication that the disc is visible in Finder or Disk Utility.

    I disconnected the Blu-ray SATA cable to test with just the Superdrive. Nothing changed.

    Next, with just the Superdrive still connected, I tried to get the system to boot from its original distribution medium (Leopard 10.5.x). But the tray simply ejects after the disc spins for a moment.

    I connected a SATA hard drive to each of the internal optical device SATA connectors. It works just fine on either connector.

    I've tried resetting the SMC and the NVRAM, with no improvement.

    It seems most likely that the Superdrive is failing. I'm just hesitant to run out and buy another before exhausting all the other troubleshooting possibilities.

    I find myself wondering if Mavericks could have somehow changed a hardware setting that 1) broke the media-sense function on both drives and 2) doesn't get reset with either SMC or NVRAM. This seems like a long shot.

    Other ideas for things I might try, before I spring for a Superdrive replacement?
     
  2. 808? macrumors 6502a

    Joined:
    Aug 4, 2011
    Location:
    Hong Kong
    #2
    Try some different disk media/brands.

    See if the optical drives are showing up in the system profiler.
     
  3. gtackett, Dec 11, 2013
    Last edited: Dec 11, 2013

    gtackett thread starter macrumors newbie

    Joined:
    May 19, 2011
    Location:
    USA
    #3
    Sorry I left that out...

    I forgot to mention those details the first time around.

    The drives do show up in System Profiler.

    I've tried multiple brands and varieties (-R, +R, +RW, even -RAM) without success. Same with CD media as with DVD.

    Another small data point: Toast Titanium 11 can see the drives and eject/load the trays. Upon loading tray with media present, it will say "Waiting..." (or similar) and a few moments later indicate that there are no media present--just as if the tray were empty. This is true for both the Superdrive and the Blu-ray.

    The real kicker is that the drives don't even recognize Apple's own system install DVDs.

    That all says bad drives rather loudly. And maybe that's the case. But both drives? And both roughly coincidental (in time) to installing 10.9?
     

Share This Page