superdrive doesn't recognize blank DVDs

Discussion in 'MacBook Pro' started by skerfoot, Jun 16, 2010.

  1. skerfoot macrumors member

    Joined:
    Feb 28, 2010
    #1
    I'm pretty sure that I'm doing this right, but something's not working. I have a new MBP, and this is the first time I've tried to burn anything to a disk. When I insert the disk a dialogue opens saying that I've inserted a blank DVD and asking what action to take. I try to open in Finder, but then it complains that "This disc can’t be used because it’s not recognized."

    I've checked system preferences and the system profiler and all of the setting seem to be fine. I've tried using different disks, DVD+R, DVD-R CD-R etc, but I can't get to the stage where I can burn anything. Am I just making a noob error and trying to burn the disk incorrectly, or is something not working right? I'm pretty sure this is how I used to do it on my old machine, but I could be wrong. I checked Mac online support and couldn't find anything relevant.

    It's not like I need to burn disks often, but it's a brand new machine and I expect things to work right...

    Thanks for any help. Sorry if it turns out that I'm just doing something dumb.


    Computer info:
    MBP
    Mac OS X 10.6.4
    2.66 GHz Intel Core i7
    4GB 1067 MHz DDR3



    Here's the drive info:
    MATSHITA DVD-R UJ-898:

    Firmware Revision: HC09
    Interconnect: ATAPI
    Burn Support: Yes (Apple Shipping Drive)
    Cache: 1024 KB
    Reads DVD: Yes
    CD-Write: -R, -RW
    DVD-Write: -R, -R DL, -RW, +R, +R DL, +RW
    Write Strategies: CD-TAO, CD-SAO, DVD-DAO
    Media: To show the available burn speeds, insert a disc and choose View > Refresh
     
  2. chrispett macrumors newbie

    Joined:
    Aug 29, 2010
    #2
    that's why it's spelt Matshita

    Same problem. whatever you do always insist on NOT having a Mac with Matshita drives. they are all *****
     
  3. xi mezmerize ix macrumors 6502a

    xi mezmerize ix

    Joined:
    May 24, 2010
    Location:
    Maryland, USA
    #3
    I have one and it works fine.
     

Share This Page