Superdrive doesn't work with El Capitan?

Discussion in 'OS X El Capitan (10.11)' started by GizmoDVD, Jun 25, 2016.

  1. GizmoDVD macrumors 65816

    Joined:
    Oct 11, 2008
    Location:
    SoCal
    #1
    Anyone know why? I have my Superdrive plugged into my iMac and it refuses to see it. I've tried rebooting, plugging it into a different USB port etc. but no matter what I do my iMac does not see the drive.

    I've verified it works on a Mountain Lion laptop.
     
  2. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #2
    Can I guess Apple has removed the driver for SuperDrive?
     
  3. GizmoDVD thread starter macrumors 65816

    Joined:
    Oct 11, 2008
    Location:
    SoCal
  4. LCPepper macrumors 6502

    LCPepper

    Joined:
    Aug 5, 2013
    Location:
    United Kingdom
    #4
    Wow... I mean, I find it really hard to believe that if it's true!

    Why would they do that? A teenie weenie file for a driver isn't going to kill them...
    --- Post Merged, Jun 25, 2016 ---
    Okay! Just decided to Google it (love a good thrill).

    Apparently they've managed to make some sort of bug/ issue, which is not surprising seen as it's their party trick nowadays.

    You might try plugging it in and restarting your Mac with it still plugged in:
    https://discussions.apple.com/thread/7259122?tstart=0

    If that doesn't work, someone else decided to have a good delve into some PLISTS:
    https://discussions.apple.com/thread/7259892?tstart=0

    They got their info seemingly from:
    http://www.hardturm.ch/luz/2011/10/...superdrive-work-with-any-mac/comment-page-12/
    -----

    Give it a whirl, see if you can get it spinning!
     
  5. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #5
    Try resetting your PRAM by cold booting while holding down the command-option-p-r key until you hear the boot chime a third time.
     
  6. RednBlue macrumors member

    RednBlue

    Joined:
    Dec 17, 2013
    Location:
    Reading UK
    #6
    I tried all of these things to no avail. Finally out of desperation I sold my Apple Superdrive and replaced it with an OWC Slim optical drive which 'just works'....every time.
     

Share This Page