Superdrive fails to burn DL DVD's

Discussion in 'MacBook Pro' started by skier777, Jan 3, 2012.

  1. skier777 macrumors 6502

    Joined:
    Jul 3, 2010
    #1
    So I need to burn some DVD's from my 2010MBP and they are around 8.4GB's so they are going onto DL DVD9's. I bought Memorex DVD+R 8x media for this purpose.

    I have the 2010 i7 15inch MBP with this DVD drive installed:
    MATSHITA DVD-R UJ-898:

    Firmware Revision: HC09
    Interconnect: ATAPI
    Burn Support: Yes (Apple Shipping Drive)
    Cache: 1024 KB
    Reads DVD: Yes
    CD-Write: -R, -RW
    DVD-Write: -R, -R DL, -RW, +R, +R DL, +RW
    Write Strategies: CD-TAO, CD-SAO, DVD-DAO
    Media: To show the available burn speeds, insert a disc and choose View

    I tried burning twice on OSX Lion with Toast Titanium 11 and both times failed at 50%, and gave an error message of something along the lines of: Focus Error, failed to switch layers, 09 01.

    Then I tried on Windows 7 Pro in Bootcamp with Imgburn and got the error shown in this photo. (I didn't know how to take a screenshot in windows)
    http://imgur.com/lxz6z

    Both times the drive failed to switch between the layers. And I'm pretty sure this is some kind of hardware or maybe firmware problem.

    If anyone knows how to solve this your help would be greatly appreciated. If not I guess I'm going to have to take it to a genius bar and see if they can do anything for me.
     
  2. ObuckiO macrumors regular

    Joined:
    Dec 9, 2011
    Location:
    Ohio
    #2
    I seen this on what sounds to be a tough issue. Maybe no help, it might give you another idea.
    I disabled the preference in Toast to open automatically when a blank CD or DVD is inserted. I close Toast and insert my blank Memorex DVD+R DL disc. I wait until the drive spins the disc up. Takes about 15 to 20 seconds or so. Once it is at full speed, I open Toast. I create a .toast image file from the source and use that as the source to burn from. I then drag the .toast image file into the disc image copy folder in Toast and fire away. I have burned 3 discs flawlessly in succession without issue. It seems I have to close Toast down and restart in between each disc and follow the same process. :apple:
     
  3. skier777 thread starter macrumors 6502

    Joined:
    Jul 3, 2010
    #3
    Did you have the same issue as I did before you started using this process?
     
  4. ObuckiO macrumors regular

    Joined:
    Dec 9, 2011
    Location:
    Ohio
    #4
    It was the same issue on another thread i found with a few people having almost exactly the same problem. I just thought it might get the wheels turning again for you. Someone also mentioned trying a differant type of disc, and it seemed more like a software issue. Hope you get it figured out.
     
  5. skier777 thread starter macrumors 6502

    Joined:
    Jul 3, 2010
    #5
    This worked even less well, returning this error almost immediately http://imgur.com/zALpY.
    Toast proceeded to write the LeadOut after like 0% completion once I clicked OK.

    Thanks. Ill look elsewhere online but i think I'm probably going to have to take it in to apple, who will no doubt have no clue whatsoever on how to fix it.
     
  6. iBrody macrumors 6502

    Joined:
    Jun 11, 2008
    #6
    I had the 'medium write error' on my old late 2008 MBP with SL discs.

    CD's would burn fine, just had the problem with burning DVD's.

    Although the error message can sometimes mean a dirty drive or incompatible media, the Genius confirmed that my SuperDrive needed replacing by just trying to burn a file using Toast.

    Whatever you do, I do not recommend using a disc cleaning kit, I tried this after someone on a forum recommended it, and the drive chewed up the brush on the disc and the spindle would not stop spinning!

    The only way for me to eject the disc was to force shut down the MBP and press down the eject button upon start up. Bits of brush hair everywhere.

    Hope your problem is not a failing drive, and if it is, hope you have AppleCare otherwise it will be quite costly to replace.
     
  7. skier777, Jan 4, 2012
    Last edited: Jan 5, 2012

    skier777 thread starter macrumors 6502

    Joined:
    Jul 3, 2010
    #7
    Im pretty sure the DVD's with brushes say that they should never be used with slot loading drives.

    I do have AppleCare and i hope that it IS a failing drive. There seems to be a weird lack of firmware for my drive so I would be happy to have it replaced.
     
  8. Jottle macrumors 6502

    Joined:
    Oct 17, 2003
    #8
    The dvd burner in my mbp is also giving me errors when trying to burn DL dvd's. It will burn cd's and regular dvd's just fine. But DL discs always error out. To be honest, I think your issue is a hardware one, like mine. My burner used to work just fine with DL discs, but now it's completely useless no matter what brand of DL dvd's I throw at it. I'd take it in for diagnosis. I'm about to do the same :)
     

Share This Page