Superdrive firmware update problem

Discussion in 'MacBook' started by jacdem, Nov 16, 2010.

  1. jacdem macrumors member

    Joined:
    Apr 9, 2010
    #1
    I have a Macbook aluminium 2008 and a superdrive firmware update 3.0 popped up in SU. The update starts but stop saying that" There was a problem installing this update. Quit all applications and try updating. If the problem continues, contact apple support." I don't have any application opened.
    I checked SU here is the output:

    This update will eliminate the noise made by the optical disk drive during wake from sleep on your Mac. This update works with the following EFI updates:

    iMac EFI Firmware Update 1.4
    Mac mini EFI Firmware Update 1.2
    MacBook EFI Firmware Update 1.4
    MacBook Pro EFI Firmware Update 1.8
    To complete the firmware update process, please follow the instructions in the updater application (/Applications/Utilities/SuperDrive Update.app). The updater will launch automatically when the installation is complete.

    I checked the firmware of my macbook and it is 1.3 and I tried to update to 1.4 but the computer shows that I don't need this update.
    I don't know what is going wrong, How can I install this update? your help will be appreciated
    thanks
     
  2. GlynJones macrumors 6502

    Joined:
    Jun 15, 2005
    #2
    Hi,
    I'm getting the exact same problem as you. There seems to be a few discussions of this on the Apple Support Forums. One in particular seems to have a fix which i'm going to try over the weekend.

    http://discussions.apple.com/thread.jspa?threadID=2649805&tstart=0

    It does involve installing 10.5 (Leopard) onto a USB drive but I don't have a problem with that.

    Hope that helps.

    Glyn.
     
  3. GlynJones macrumors 6502

    Joined:
    Jun 15, 2005
    #3
    Success!

    Installing Leopard on a USB drive then upgrading to the latest version of Leopard prompted the Superdrive 3.0 firmware upgrade. This then worked fine.

    Hope that helps.

    Glyn Jones.
     

Share This Page