Superdrive won't burn anymore

Discussion in 'macOS' started by stenosis.kill, Feb 21, 2008.

  1. stenosis.kill macrumors member

    Joined:
    Feb 11, 2008
    Location:
    Germany
    #1
    Every time i try to burn a cd/dvd on my mbp no matter which burn application i choose.. the superdrive likes to rejeckt the medium since the 10.5.2 update and it says there was an intern error. :confused:

    Is there a way to check what's wrong with my superdrive, what can i do?
     
  2. merc669 macrumors 6502

    merc669

    Joined:
    Jun 7, 2006
    Location:
    Southern MD, USA
    #2
    I am basically having the same issues. I can burn a CD but a DVD no. Keeps giving me a Media Error. Tried several Brand New Fuji DVD+R and all have the same error. Borrowed some DVD-R (Verbatim) to see if they work. I would be interested if anybody else is having issues. I know it worked in Tiger. But have never tried burning in Leopard until this weekend. I am also on 10.5.2..

    Bill......:apple:
     
  3. cawesjmu macrumors 6502

    Joined:
    Apr 4, 2004
    Location:
    Richmond, VA
    #3
    always ejects media

    My superdrive in my MBP will read a commercial DVD, or CD, but if I want to burn a blank disc, either DVD, or CD, it will eject it everytime. I put it in, and it spins around a few times, and then pops out. It doesn't give me any kind of error or warning. I'm taking it in to the Apple store on friday, cus I think the drive is just broken. This was a problem before leopard, but I haven't needed the burner too much, so I've just put it off. Not sure, but it could be that your drive is on its way to behaving like mine. Hope you find a fix.
     
  4. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #4
    My MBP drive also won't burn most blank CDRs that I try.
     
  5. Jolea macrumors newbie

    Joined:
    Feb 28, 2008
    #5
    There is Help!!

    Ok so i had the same thing happen and i tried everything. I tried reinstalling the os and repairing disk permissions and everything. And what ended up work was installing the latest security update and shuting down my computer for 48 hours, and unplugged it. that clear out all of the temp data. After that it reconfigures the laser in your superdrive and it worked just fine after that. I was so happy cause the guy at Mac Docs said i need a new super drive which cost $200 to replace and i was freaking out and now it works!! Good Luck!!!:apple:
     
  6. Applespider macrumors G4

    Applespider

    Joined:
    Jan 20, 2004
    Location:
    looking through rose-tinted spectacles...
    #6
    You don't need to do it for 48 hours. Mine wasn't burning so I called Applecare.

    They had me unplug everything from 15 seconds, then plug things back in and reset the PRAM, then it worked. ;)
     
  7. stenosis.kill thread starter macrumors member

    Joined:
    Feb 11, 2008
    Location:
    Germany
    #7
    This worked like charm
    thank you very much Applespider and Jolea :)
     
  8. Kar98 macrumors 6502a

    Joined:
    Feb 20, 2007
    #8
    Hmmm, my "superdrive" has turned itself into a "combo drive". I wonder if this will help.
     
  9. Kar98 macrumors 6502a

    Joined:
    Feb 20, 2007
    #9
    Well, I don't know yet if this has fixed the problem, but now the fan is running at full speed.

    PS: Because the Intel minis require a SMC reset and not a PRAM reset...
    Fan speed fixed, but the drive still doesn't burn DVDs.
     

Share This Page