Supposedly permanently deleted contacts have reappeared after iOS 8 restore

Discussion in 'iPhone Tips, Help and Troubleshooting' started by RocknRollTim, Sep 23, 2014.

  1. RocknRollTim, Sep 23, 2014
    Last edited: Sep 23, 2014

    RocknRollTim macrumors newbie

    Joined:
    Sep 23, 2014
    #1
    Hi there,

    I wanted to know whether anybody else has encountered this issue on their iPhones or whether it's just mine. Basically after restoring IOS 8 due to an endless loop with the Apple logo screen after resetting my iPhone 4S due to a really bad laggy issues after upgrading from IOS 7.1.2, I re-imported all the contacts from the sim using the option from the Mail and Contacts section of the Settings section and all contacts I supposedly permanently deleted have reappeared on the phone again with some of the contacts reverting to their old numbers, I can confirm these contacts aren't on the sim and are up-to-date as I temporarily placed the sim into another phone whilst I was getting the power button fixed at a local mobile shop, if the contacts aren't stored on the sim then where are they coming from? Your help would be much appreciated.

    Many thanks,

    RocknRollTim
     
  2. dacreativeguy macrumors 68020

    Joined:
    Jan 27, 2007
  3. RocknRollTim thread starter macrumors newbie

    Joined:
    Sep 23, 2014
    #3
    I hope not dacreativeguy, I terminated my social networking accounts nearly 4 years and I never store any personal information in the cloud, I would like to be famous one day but not very famous though even if I'm known across many forums on the Internet. Anyway forums are great places to ask questions as well as starting discussions. :)
     
  4. dacreativeguy macrumors 68020

    Joined:
    Jan 27, 2007
    #4
    I had trouble restoring my 4s backup to iPhone 6 as well. Ended up starting fresh and manually moving data and things turned out ok.
     
  5. OldMacDonald1, Sep 23, 2014
    Last edited: Sep 24, 2014

    OldMacDonald1 macrumors member

    Joined:
    Sep 22, 2014
    Location:
    Los Angeles
    #5
    This seems possibly related to iCloud.

    If you turn off sync, for instance, then delete your contacts, then turn it back on, your phone will say, "All these contacts are in the cloud and aren't on the device. I'll sync them now." The device wouldn't know you deleted the contacts because your phone was off.

    Maybe something like this happened along the line. :eek:
     
  6. RocknRollTim thread starter macrumors newbie

    Joined:
    Sep 23, 2014
    #6
    @dacreativeguy May I ask how you went about moving data after a fresh restore as I had to start from scratch.

    @OldMacDonald1 I'll check the sync options for iCloud and let you know how I get on, thank you for the suggestion. :)
     
  7. OldMacDonald1 macrumors member

    Joined:
    Sep 22, 2014
    Location:
    Los Angeles
    #7
    No prob. Let me know what you find out.
     
  8. RocknRollTim thread starter macrumors newbie

    Joined:
    Sep 23, 2014
    #8
    Hi OldMacDonald1,

    Sorry for taking the time in getting back to you.

    I managed to resolve the problem using the suggestion you suggested and it worked like a treat, I first turned on Contacts in Settings > iCloud on my iPhone, merged all contacts, deleted each contact individually and re-imported the ones of the sim by going to Settings > Mail, Contacts, Calendars > Import SIM Contacts.

    The contacts from iCloud must have been there since I activated this feature on IOS 5 3 years ago without me realising and thought I deleted all data from the cloud as normally sync my data to the PC using iTunes due to no storage capacity limitations. :)

    Many thanks,

    RocknRollTim
     
  9. OldMacDonald1 macrumors member

    Joined:
    Sep 22, 2014
    Location:
    Los Angeles
    #9
    Hey RocknRollTim,

    I thought it had something to do with iCloud. Thanks for explaining your fix. Might come in handy some day.

    Glad it worked out!

    OM
     
  10. RocknRollTim thread starter macrumors newbie

    Joined:
    Sep 23, 2014
    #10
    Hi OM,

    You can do it that way too but this is the method I know best and is possibly the quickest.

    You're very welcome and hope this helps other people who have the same problem and it's a pleasure to participate in forum discussions that can help other people with a same or similar issue.

    Same here and thank you for all your help.

    Thanks,

    RocknRollTim
     

Share This Page