Surround error

Layway

macrumors newbie
Original poster
Nov 6, 2015
3
0
Hi
Using Apple TV 4 and has a HDMI switch connected, from that switch the HDMI cable goes out to the TV and sound digital toslink goes from the switch to my surround receiver. The sound is playing out fine in the 2 front speakers and the front middle speaker, but NOT my 2 rear speakers!!!

Anyone with a solution or an answer why this is?
Thnaks.
 

seadragon

Contributor
Mar 10, 2009
1,413
1,458
Hi
Using Apple TV 4 and has a HDMI switch connected, from that switch the HDMI cable goes out to the TV and sound digital toslink goes from the switch to my surround receiver. The sound is playing out fine in the 2 front speakers and the front middle speaker, but NOT my 2 rear speakers!!!

Anyone with a solution or an answer why this is?
Thnaks.
You may try going into the settings and set the audio to Surround instead of Auto. There is an issue that many of us are experiencing where the ATV will not send surround info if it is set to Auto.

I just got a new receiver (Yamaha RX-A3050) and it only receives PCM from the ATV if the ATV audio is set to Auto. If I set it to Surround, then the receiver gets the digital surround signals. Worth a try.
 

Snoopy4

macrumors 6502a
Dec 29, 2014
661
2,921
You may try going into the settings and set the audio to Surround instead of Auto. There is an issue that many of us are experiencing where the ATV will not send surround info if it is set to Auto.

I just got a new receiver (Yamaha RX-A3050) and it only receives PCM from the ATV if the ATV audio is set to Auto. If I set it to Surround, then the receiver gets the digital surround signals. Worth a try.
On Yamaha's I've found they are touchy and always set everything to DD instead of PCM.
 

zinned

macrumors regular
Apr 30, 2015
102
22
Getting PCM is not a bad thing per se.

The thing is that one gets PCM 7.1 for every surround signal when the setting is "Auto", no matter if it's 5.1/6.1/7.1 etc.

When using the "Dolby Surround" setting you get 5.1 no matter what you feed the ATV4 with.
 

Layway

macrumors newbie
Original poster
Nov 6, 2015
3
0
I tried both auto and surround same result.
1) Is the HDMI switch ok, and should be able to "export" surround to Apple TV?
2) Is it a bug from Apples side, and maybe will be fixed via next software update?
3) The movies etc i´m trying to play, do they really have surround "in them" Tried different TV shows on Netflix and HBO, and also Captain America through Netflix.

Just think it is weird my center speaker is playing, would think if it were just stereo that only my two front speakers would play and not the middle. It seems somewhere in between this i have now!