Suspiciouc file activity. What could it be?

Discussion in 'macOS' started by definitive, May 11, 2010.

  1. definitive macrumors 68000

    definitive

    Joined:
    Aug 4, 2008
    #1
    Just booted up the system (10.6.3), and got a prompt that a file is trying to access the internet. I don't remember installing anything new on this system yesterday, so I'm not sure what's going on. Its name is rsmac_3696, and here's the info for it:

    [​IMG]

    I've checked the directory, and it contained the files I've posted below. I'm thinking it could have something to do with the Adobe CS5 trial that I got off of Adobe's site about five days ago (maybe these are the download manager files?

    [​IMG]

    There's also a readme file which contains the following at the beginning:

     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    I have it too, so maybe it came with CS5 or Akamai (Adobe downloader). Don't worry about it
     
  3. andiparker macrumors newbie

    Joined:
    May 11, 2010
    #3
    Yes its relates to CS5, its the RedSwoosh Download Agent (Acquired by Akamai a few years back) - essentially its a Peer-to-Peer distribution system.
     
  4. northernbaldy macrumors 6502a

    northernbaldy

    Joined:
    Jan 13, 2010
    Location:
    the north, UK
  5. Antoni macrumors newbie

    Joined:
    May 11, 2010
    #5
    Unistall rsmac_3696 ...

    Hi,

    I try this...

    1 Open a Terminal sesion...
    2 type: /Applications/Akamai/AdminTool uninstall -force

    or

    /Applications/Akamai/AdminTool -uninstall force

    I don't remember... sorry. You can read the file in Akamai directory: readme.txt

    thats all!
     
  6. nicolaiuta macrumors newbie

    Joined:
    May 11, 2010
    #6
    well actually, i've been trying to delete this file from my mac, but I couldn't because it specifies that the file is like "currently in use". Eventhough all my programs are closed. And since I downloaded CS5, the internet got so slow, I gotta wait ages for simple video to get loaded. it must propably be that "rsmac_3696" wich slows it all. So I just uninstalled all files coming from CS5, but exept for that one, so I hope that your solution, Antonio, will. I'll try.
     
  7. nicolaiuta macrumors newbie

    Joined:
    May 11, 2010
    #7
    Antonio-> I tried what you said, but didn't do anything, could copy/paste the readme file bit where it explains how to do it, because as i said, I just deleted everything exept th rsmac3696. Thanks
     
  8. jocamero macrumors regular

    Joined:
    Jul 11, 2008
    #8
    The following worked for me. Thanks.

    (I checked in the Activity Monitor and rsmac_3696 is no longer running.)

     
  9. nicolaiuta macrumors newbie

    Joined:
    May 11, 2010
  10. Alyssa macrumors newbie

    Joined:
    Sep 29, 2003
    Location:
    Texas
    #10
    Terminal is an application located in the Applications folder under Utilities folder
     
  11. Larance macrumors newbie

    Joined:
    May 13, 2010
    #11
    rsmac-3696

    Follow Antoni's May 11, 2010 instructions using the Terminal Folder. If you typed in the text line exactly as Antoni wrote you should receive another text line in the same Terminal window stating, "Uninstallation successful."

    I make sure I'm always completely Updated before looking for this rascal 'cos it automatically gets loaded onto your system whether or not you complete a successful Akamai (crap, junk, sad, twisted, mental) download from anyone, not just Adobe.

    Also, Adobe offers you the option to not use the Akamai Downloader, which is what I ALWAYS choose... not because it never works for me but because a simple 1-file download isn't worth the disasters Akamai causes on my systems.

    And, the Terminal folder is in the Applications folder. Terminal is a DOS-type script, so simply type in Antoni's second line starting with (include the Forward Slash) /Applications..., then press your "return" key, then wait for the confirmation.

    Then restart and do a search for Akamai (crap, junk, sad, twisted, mental).

    Hope this helps. Thanks, Antoni.
     
  12. foltzwerk macrumors newbie

    Joined:
    May 13, 2010
    #12
    "uninstall -force" works for removing akamai admintool and rsmac / rsmac_3696

    Confirming that this worked for me. Here are details:

    [​IMG]
    (machine name and user name redacted for privacy)

    Executing the command mentioned above stopped the rsmac_3696 process and removed the entire Akamai directory (and its contents) from my Applications directory. About 30 seconds after I entered the command the terminal displayed Uninstallation complete.

    Thank you, it's nice to have closure.
     
  13. YrbkladyCarla macrumors newbie

    Joined:
    Jun 8, 2009
    Location:
    San Jose, CA
    #13
    Yippee!

    Worked perfectly!! Thank you so much! Little Snitch was working overtime!;)
     
  14. Whitewolfe macrumors newbie

    Joined:
    Jun 14, 2010
    #14
    not to sound stupid but

    If I go thru terminal- and uninstall this rsmac_3696 - does that mean anything I loaded containing it disappears as well?

    Thanks in advance this thing is driving me nuts
     
  15. jbutler404 macrumors newbie

    Joined:
    Oct 29, 2010
    #15
    Akamai: what a pain!

    Please help!
    I had the same problem as everyone on this forum. Managed to get Akamai folder to the trash + delete it. Can find no evidence of anything Akamai on my Mac including the file mentioned.
    My Console is, however, permanently on with WARNING because Akamai won't stop transmitting to my machine as it's looking for the Loader.
    All this happened because I very reluctantly downloaded PhotoShop CS5 trial for a course when I was perfectly happy with Pixelmater but the tutors said I needed Adobe.
    How can I stop this please?
    I really hope I don't have to redownload CS5 to do the forced uninstall.
    Thanks.
     
  16. BENI, Feb 2, 2011
    Last edited by a moderator: Feb 3, 2011

    BENI macrumors regular

    BENI

    Joined:
    Jun 27, 2009
    #16
    I don't know if everyone will be able to find this but I just searched "akamai" in finder and found the akamai uninstaller.

    it seems all this terminal stuff might be kind of overkill if you just want to get rid of, when they supply an app for that job already....

    mac search really is worth a try sometimes people!

    to be quite honest - i'd try and re-download and then run the uninstall package that comes with it.

    YOU DON"T HAVE TO COMPLETE THE DOWNLOAD OF PS CS5!!!!
    just download the initial package which is akamai - and then cancel the download of PS.
    then open the dmg and run the uninstall.
    it might say that there is nothing to uninstall so just run the app and then do it.

    it isn't anything scary it's just adobe's download helper or something like that.
     
  17. zard macrumors newbie

    Joined:
    May 15, 2011
    #17
    Did you try uninstalling Photoshop? Simply drag it from applications to the trash.

    There is another option, which is to explicitly disable this service in your application layer firewall. Go to System Preferences under the Apple menu at the top right of the screen. Then go to Security > Firewall. click the radio button 'Set access for specific services and applications'. Now block incoming connections for this service, or simply remove it from the list.
     
  18. iThinkergoiMac macrumors 68030

    Joined:
    Jan 20, 2010
    Location:
    Terra
    #18
    Why is everyone working so hard to delete a tiny app that's not even 10 MB and uses almost no system resources?
     
  19. cinder macrumors member

    Joined:
    Jun 26, 2004
    Location:
    Seattle
    #19
    Because sometimes it goes haywire and starts devouring your processors.
    Like what's happening right now on my machine.

    netsession_mac_b94eec3 is sucking up 52% of one of my processor cores.

    and now it is gone.

    Thanks peoples.
     
  20. iThinkergoiMac macrumors 68030

    Joined:
    Jan 20, 2010
    Location:
    Terra
    #20
    Wha?....

    You just linked to Windows software that won't run on a Mac...
     
  21. Josev macrumors newbie

    Joined:
    Jun 8, 2011
    #21
    I'm glad I found this thread

    My Macbook has been overheating, or at least the fan speed made it seem that way, over the last 6 months or so. There was always an activity called Netsessions showing in the Istat bar when this happened. Hopefully removing the Akamai app will solve the problem.
     
  22. ELMI0001, Jun 11, 2011
    Last edited: Jun 11, 2011

    ELMI0001 macrumors 6502

    ELMI0001

    Joined:
    Jan 5, 2009
    Location:
    Olympic Hills GC
    #22
    Maybe it's CloudApp?

    I don't have CS5 installed nor have I ever, but I just got this on a restart. Only thing new is CloudApp.

    [​IMG]
     
  23. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #23
    Dude, use the timg tag instead of the img tag. That huge image is messing up the formatting of the thread and its way too big
     
  24. ELMI0001 macrumors 6502

    ELMI0001

    Joined:
    Jan 5, 2009
    Location:
    Olympic Hills GC
    #24
    ^ good call.

    I found the Akamai folder in the App folder and ran the uninstaller. No need to get into Terminal.
     
  25. DeltaWarDog macrumors newbie

    Joined:
    Jun 26, 2011
    #25
    similar problem

    Whenever I restart my iMac, I get "Do you want the application 'netsession_mac_361e3f9' to accept incoming network connections?" Is this the same application?
     

Share This Page