Suspicious Process - Spotlight Suggestions [solved]

Discussion in 'OS X Yosemite (10.10)' started by Reimer, Nov 23, 2014.

  1. Reimer, Nov 23, 2014
    Last edited: Nov 27, 2014

    Reimer macrumors regular

    Reimer

    Joined:
    Sep 15, 2006
    #1
    [​IMG]

    [​IMG]


    http://i.imgur.com/LrqdHuJ.png



    I saw this suspicious looking process in activity monitor tonight. It's there upon boot up. It's categorized under as Spotlight Web Content. I've even rebooted to find it changed to another address i.e www.netflix.com.

    The third link shows outgoing connections it's making. I've played around and tested to see if those connections are being made while I type an address in Spotlight and they do.

    So is this really Spotlight just doing it's thing or is this something to be worried about?

    Please let me know if you have this process as well.

    Thanks

    *edit*

    It turned out to be Spotlight Suggestions.

    To disable, open System Preferences, go to Spotlight. Uncheck "Spotlight Suggestions" and "Bing Web Searches".

    You also have to disable it in Safari as well via Safari Preferences -> "Search" -> Uncheck "Include Spotlight Suggestions"
     
  2. Fzang macrumors 65816

    Fzang

    Joined:
    Jun 15, 2013
    #2
    Have the same process, so there's probably nothing to worry about.
     

    Attached Files:

  3. djtech42 macrumors 65816

    djtech42

    Joined:
    Jun 23, 2012
    Location:
    West Chester, OH
    #3
    Looks like the website subprocesses of Safari, unless I'm missing something...
     
  4. Reimer thread starter macrumors regular

    Reimer

    Joined:
    Sep 15, 2006
    #4
    It's not since it would be "Safari Web Content" instead of "Spotlight Web Content".

    Thanks Fzang

    So, it's likely legitimate but just not entirely sure what it's doing or its purpose. Best guess is it's the process that searches the web when you do searches on Spotlight.


    What about "com.apple.internetaccounts"? Should that always be running? I don't use keychain or Safari much at all.
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    Totally normal. It is Spotlight's "suggestions". If you turn that off in Spotlight settings you will see those random site/process no longer will appear.

    What happens is you start searching for a document called "new shoes" and as you are typing "N E" it starts looking for suggestions and preloads Netflix in this example.

    I found it annoying and turned it off.
     
  6. Reimer thread starter macrumors regular

    Reimer

    Joined:
    Sep 15, 2006
    #6
    Thank you.

    They could have done a better job with naming this process. Making it into random URLs threw me off.
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    Agreed. It scared me too the first time I saw a random site in Activity Monitor like that.
     
  8. Reimer thread starter macrumors regular

    Reimer

    Joined:
    Sep 15, 2006
    #8
    Hmm. I went ahead and disabled Spotlight Suggestions and Bing Web Searches in Spotlights preferences, rebooted, and it's still there.

    It doesn't seem to go away.

    I just tried disabling it on another system I have here and it's the same result. Both on 10.10.1
     
  9. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #9
    Hmmm... I don't know. That killed it for me and I have not seen it since.
     
  10. Reimer thread starter macrumors regular

    Reimer

    Joined:
    Sep 15, 2006
    #10
    I was able to stop the process from coming up. I thought I should follow up on this in case someone else stumbles upon this thread.

    You were right that I had to disable "Spotlight Suggestions" and "Bing Web Searches" in Spotlight Preferences.

    But you also have to disable it in Safari as well via Safari Preferences -> "Search" -> Uncheck "Include Spotlight Suggestions"

    It's gone now


    Thanks again :cool:
     
  11. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #11
    Ahh... thanks for following up and that makes sense. I have that on but never use the smart search in Safari, so I guess just the other two options turned it off for me. I have now also turned off the Safari setting thanks to your tip.
     
  12. Liteowl macrumors newbie

    Joined:
    May 26, 2015
    #12
    Can't get rid of them

    I have the checkboxes in System Prefs > Spotlight and Safari > Preferences > Search disabled, and I still have these processes on boot, before even opening Safari or Spotlight.

    Anyone else have this?
     

Share This Page