Swapping ipsw's

Discussion in 'iOS 8' started by Hargobind, Jun 4, 2014.

  1. Hargobind macrumors member

    Hargobind

    Joined:
    Jun 14, 2013
    Location:
    KC, MO
    #1
    Hi,
    Just wondering..I know it's stupid, but what would happen if you tried to install an ios 8 beta ipsw for iPhone 4s on iphone 4???
     
  2. batting1000 macrumors 604

    Joined:
    Sep 4, 2011
    Location:
    Florida
    #2
    You'd get an error saying the build isn't compatible with your device.
     
  3. Hargobind thread starter macrumors member

    Hargobind

    Joined:
    Jun 14, 2013
    Location:
    KC, MO
    #3
    Any way to get it through...I heard of someone doing this before...
     
  4. batting1000 macrumors 604

    Joined:
    Sep 4, 2011
    Location:
    Florida
    #4
    No, lol. The .ipsw is made for a specific device and that is all. iOS 8 does not support the iPhone 4 and there is no workaround.
     
  5. AaronM5670 macrumors 6502

    AaronM5670

    Joined:
    Apr 19, 2012
    Location:
    London
    #5
    The iPhone 4 has a far inferior processor and an inferior type of RAM to the 4S - there is a very simple reason why Apple chose not to support it - because the specs are not good enough, it would give a terrible user experience compare to previous versions of iOS.
     
  6. noisycats macrumors 6502a

    noisycats

    Joined:
    Jun 1, 2010
    Location:
    The 'ham. Alabama.
    #6
    I believe the swamp is not possible regardless of OS iOS after iPhone 4. Since you have the 4S I think you're out of luck regardless.
     

Share This Page