SwapTunes and 1.1.3?

Discussion in 'iPod touch' started by itouch2007, Feb 2, 2008.

  1. itouch2007 macrumors member

    Joined:
    Jan 31, 2008
    #1
    Hi,

    anyone managed to run SwapTunes on 1.1.3 firmware?

    When I try to install it tells me I need 1.1.2, is there any way around it?

    Thanks.
     
  2. xcapepr macrumors newbie

    xcapepr

    Joined:
    Jan 8, 2008
    Location:
    San Juan, Puerto Rico
    #2
    Either revert back to 1.1.2 or wait for the developer to update the application.

    I need this app to be able to synchronize contacts between the PC and laptop.
     
  3. rubberfish613 macrumors newbie

    Joined:
    Feb 8, 2008
    #3
    I fixed the App myself:

    I fixed the App by changing all of the codes (in the swaptunes.sh file) from ".../root/..." to ".../mobile/..." I was bored. I will now try to fix it so that I can have three libraries instead of just 2. Simply put the Swaptunes.app file into /Applications folder via SSH or something. Your welcome.
    Edit: I made a mistake the first time that I posted. The App had one flaw. It may have more, so if any one who tests it finds it to work well, please reply with your results
     
  4. itouch2007 thread starter macrumors member

    Joined:
    Jan 31, 2008
    #4
    thanks mate, I'll give it a try and see how it goes.
     
  5. itouch2007 thread starter macrumors member

    Joined:
    Jan 31, 2008
    #5
    not sure if I'm doing something wrong, but nothing happens when I run swaptunes you have provided?

    I looked in the script and as I understand it should create Itunes_Control2 folder, but it doesn't?

    Any idea why?

    Thanks
     
  6. rubberfish613 macrumors newbie

    Joined:
    Feb 8, 2008
    #6
    Figured it out

    Yeah, I got the problem too. I'm Not sure why, but when I do it I have to close the Music and Videos App (for iphone just ipod.app) and then it recognises the change. Try it, and if it doesn't work, come back later and post. I will have made a new version by then.
    :apple:rubberfish613
    Edit: also, if you don't know how to close and app, you open the app, hold the home button (the one with a square on it) until it goes to the home screen. Do this with ipod/ music and videos app(s)
     
  7. rubberfish613 macrumors newbie

    Joined:
    Feb 8, 2008
    #7
    Updated program:

    I found a few more glitches that really confused the ipod. Try this one.
    signed,
    Rubberfish613
    P.S. note the new icons;)
     

    Attached Files:

  8. itouch2007 thread starter macrumors member

    Joined:
    Jan 31, 2008
    #8
    thanks mate, I've fixed this in "sh" script already, as some of links where still for "root" and not "mobile".

    Anyway, still doesn't work, looks like there is more problems that we can understand.

    I even tried to create iTunes_Control_2 manually and moved my library to this new folder. After that if I go to ipod music I can still see songs, but all album artwork is gone!

    So looks like in 1.1.3 something has been changed the way apple stores music library or something. Didn't have time to dig deeper, but I'll try tonight.
     
  9. xuset macrumors newbie

    Joined:
    Feb 28, 2008
    #9
    Swaptunes in 1.1.3 working!

    Hello there,

    I have been playing a bit with this script, and found several things that needed be changed: of course the paths, that had already been repaired by rubberfish613.
    However it still didn't work on my iphone and I finally found out why: the output of the ps instruction was cutting the lines to the width of the console, this means that the grep instruction couldn't find the MobileMusicPlayer process and thus it couldn't kill it. For that reason the whole application didn't work properly.

    The solution is simple, you can add the option -w in the ps instruction. In case you prefer, I have already done it for you :)

    Good luck!!
     

    Attached Files:

  10. darkice81 macrumors newbie

    Joined:
    Oct 2, 2007
    #10
    Can someone post a download link so i can get swaptunes.app to replace the .sh file? It seems like i can't find it anywhere because it's already available on installer, so no one bothers hosting it.

    sorry if this sounds noobish, i'm definitely not at the level you guys are. i was just gonna tinker around with it and see if i can get it working on my 1.1.3, but if anyone wants to provide some step-by-steps, that'd be awesome too.
     
  11. rubberfish613 macrumors newbie

    Joined:
    Feb 8, 2008
    #11
    der der-der

    I know it is complicated but if you look right above your post, I posted "swaptunes.zip" which contains swaptunes.app:rolleyes:
     
  12. UniversalmindX macrumors newbie

    Joined:
    Mar 2, 2008
    #12
    Could you run me through the process of getting it from my pc to the phone? I'm pretty new at the so any help would be appreciated
     
  13. bbuz macrumors newbie

    Joined:
    Mar 29, 2008
    #13
    This worked for me, but i had to change swaptunes.sh permissions to 755

    (i uploaded SwapTunes.app to /Applications/ with cuteFTP, with SHH active in my ipod touch)

    thanks
     

Share This Page