SwiftKey Dissapearing

Discussion in 'iOS 8' started by TheKrs1, Sep 18, 2014.

  1. TheKrs1 macrumors 6502

    Joined:
    Apr 11, 2010
    #1
    So I woke up this morning and SwiftKey was working fine. I had to go to a blood test and at the office was required to shut off my phone. When I booted it back up, anyplace that needs a keyboard SwiftKey never comes on the screen. Just a full screen of the app, with the flashing text cursor. It happens across all apps. Turning off SwiftKey in settings.app returns functionality of my other keyboards.

    I deleted swiftkey, removed it, reinstalled and even rebooted... Nothing is fixing this issue.

    Any tips?
     
  2. hasanahmad macrumors 65816

    Joined:
    May 20, 2009
    #2
    bug in app
     
  3. afsnyder macrumors 65816

    Joined:
    Jan 7, 2014
    #3
    That's a swiftkey bug... TouchPal doesn't do that.
     
  4. TheKrs1 thread starter macrumors 6502

    Joined:
    Apr 11, 2010
    #4
    Hmm. That sucks. I figured completely removing it would reset whatever bug it caused... apparently not.

    *EDIT*
    I just got it back. I had to turn "full access" off and back on after the fresh install. Think that's what the issue was.
     
  5. Chrislr24 macrumors member

    Chrislr24

    Joined:
    Apr 9, 2014
    #5
    Have you tried removing all the other keyboards besides SwiftKey?
     
  6. macduke Suspended

    macduke

    Joined:
    Jun 27, 2007
    Location:
    Central U.S.
    #6
    I haven't been able to get Flesky to work on my iPad Mini Retina, so I tried out some others like SwiftKey and they don't work either. I've tried reinstalling everything in the settings, reinstalling the apps from the device, and rebooting several times. Still can't find a solution to the problem. Flesky is just invisible, and SwiftKey has a blank keyboard base that is semi-transparent. I can't believe how buggy this launch is.
     
  7. b.c. macrumors 6502

    Joined:
    Nov 5, 2008
    #7
    I noticed the same thing on my iPad Air, immediately after installing Swiftkey.
    The very first time I activated it, its keyboard came up normally. I closed the app I was using, but as soon as I went back to an app such as Notes, or put the cursor in Safari's address bar - the keyboard was missing and no way to switch back to any other keyboard or the default - impossible to enter any text. The only thing that would bring back the default keboard was to go back to Settings/General/Keyboards and delete Swiftkey.

    re-installing it made no difference, as soon as it was installed and selected, no keyboard at all would be visible when text entry was expected.

    But I did notice one thing however - this keyboard disappearing act seems to coincide with the Allow Full Access setting of Swiftkey turned OFF. Turning access ON seemed to enable all the keyboards.

    seems to be a bug. i.e. with Swiftkey full access OFF, then once you bring up the Swiftkey keyboard, ALL the available keyboards disappear

    p.s. I just noticed that on my iPhone 5, Swiftkey does work properly with Allow Full Access = off. So maybe a bug specifically with Swiftkey on iPad
     
  8. b.c. macrumors 6502

    Joined:
    Nov 5, 2008
    #8
    update - found this tip on another site:

    it turns out that if you have Guided Access enabled in iOS (Settings -> General -> Accessibility -> Guided Access), then somehow this interferes with these 3rd party keyboards.

    I had Guided Access turned on a long time ago, just to test it, and I had forgotten it was on. After turning it off, now Swiftkey works properly even with Full Access = OFF

    btw, I also have Swype keyboard installed and it had the same problem with Guided Access turned on - there is even a note in Swype's app warning you to turn off Guided Access

    so maybe those of you with similar problems with other 3rd party keyboards should also check this Accessibility setting
     
  9. EJ8 macrumors 6502a

    EJ8

    Joined:
    Oct 13, 2010
    #9

    Yes. Get a different kind of phone. Because it doesn't work. . No really the tip is - wait. Until Apple makes iOS 8 not suck as much.
     
  10. TheKrs1 thread starter macrumors 6502

    Joined:
    Apr 11, 2010
    #10
    I missed this update. Thanks for the tip!
     

Share This Page