Swirly MMS and AT&T Help

Discussion in 'Jailbreaks and iOS Hacks' started by BullittMustang, Oct 17, 2008.

  1. BullittMustang macrumors 6502a

    Joined:
    Mar 27, 2008
    #1
    Does anyone know how to make Swirly MMS work with AT&T phone service? If anyone is having success, please post the necessary steps and settings to make this work. Thanks
     
  2. calvy macrumors 65816

    Joined:
    Sep 17, 2007
    #2
    It doesn't work with AT&T. Sorry, I know, it sucks.
     
  3. Vonswanko macrumors regular

    Joined:
    Oct 18, 2008
    #3
    I can confirm that the following steps will allow Swirly to work on your AT&T iPhone. I got this from the swirly forums and it worked for me.I think you need family plan with messaging on it also, which I do.

    First, you will need a regular AT&T/Cingular phone. I used a old Nokia 2610. You should be able to use any phone as long as it is Media Net compatible.

    Take the SIM from your iPhone, Insert it in to a standard phone, Make a phone call, wait about 5 minutes.

    After 5 minutes go to the following link,

    http://mymedianet.wireless.att.com/app/MC/Default.aspx

    Enter in your mobile number(it might say your phone is not supported.. if so wait a little longer and try again), then at the next screen it will ask for a 4 digit code.

    The 4 digit code will be sent to your phone via Text message.

    Enter the code in on the website and then you should be able to access the main Media Net site.

    Now send a mms. It will take some time for the network to recognize the phone. Be patient. Took me about 10 minutes. Dont continue until you have successfully sent a message.

    Now take out the sim card and place it back in the iPhone.

    Make sure the Swirly MMS Settings are as follows...

    MMSC: mmsc.cingular.com
    Proxy: 066.209.011.032

    leave apn, username, and password fields blank..

    Image Size: Maximum
    UserAgent: Nokia_N95.
     
  4. Knowlege Bomb macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #4
    I'm in the process of doing this.... Anybody confirm that this works??

    EDIT : Didn't work for me.
     
  5. Vonswanko macrumors regular

    Joined:
    Oct 18, 2008
    #5
    Did you wait until you could actually send a MMS with the phone your iPhone sim was in?
     
  6. xsecretfiles macrumors 6502

    Joined:
    Aug 1, 2008
    #6
    thanks "vons" I didn't actually follow your steps, but I think I was missing a setting LOL

    Here is what I did though. I went to the AT&T store this morning and told them that my iPhone got lost and that I wanted a new sim card to use with a different phone, of course I lied LOL

    Also told them to add the media package. They did and replace the sim card in my jailbroken phone. Anyways I didn't get it to work until now reading the settings above. It worked
     
  7. vm7118 macrumors regular

    Joined:
    Nov 2, 2007
    Location:
    NJ, USA
    #7
    are you now using the original iphone SIM in the iphone, or the new one that they gave you?

    do you still have visual voicemail?

    do you still have the iphone data plan now that they added the mediaNET thing?

    people on other forums have said their ATT person tell them the iphone data plan and the medianet are mutually exclusive, i.e. cannot be on the same plan at the same time.

    so adding the mediaNET might have pushed off the iphone data plan, which kills visual voicemail. let me know!
     
  8. xsecretfiles macrumors 6502

    Joined:
    Aug 1, 2008
    #8

    I'm using the NEW sim they gave me

    Yup, visual mail not working :(. I'm sure there is a fix, I haven't researched

    No, they removed the iphone data plan and added this new medianet plan

    You might be right about the visual mail thing...which I really don't care for. it was fun the first few weeks :)

    I guess we can't have everything...
     
  9. Vonswanko macrumors regular

    Joined:
    Oct 18, 2008
    #9
    I still have visual voicemail and the iPhone data plan.I am still using the original iPhone sim card also. Everything is still the same except i can now send MMS.
     
  10. Alisstar macrumors 6502

    Alisstar

    Joined:
    Jul 12, 2008
    Location:
    Orlando, FL
    #10
    I'm about to do this. I'm pretty confident this will work. I just have a quick question. Do you know if I'll be charged per message or will I not see any additional charges?
     
  11. Vonswanko macrumors regular

    Joined:
    Oct 18, 2008
    #11
    Well I have been using if for about 10 days now. My bill should come in any day now, I'll let you know if there are any extra charges. But I do have unlimited texting on a family plan. So might be different than your plan.
     
  12. Knowlege Bomb macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #12
    17 minutes and counting and my device is still not supported by media net.

    2nd time attempting this btw.
     
  13. SFLG35 macrumors newbie

    Joined:
    Oct 22, 2008
    #13
    hello

    i did this and got the code sent to my phone and i entered and it worked.
    now i am trying to send a mms and it sends but then says error could not send message. i am using a blackjack 2. anyone have any ideas?

    thanks

    edit: so i was able to send the a message, and it worked on the iphone.
    so just playing around with it i changed the user agent back to iphone and tried to send another one and it errored out. so i put it back to nokia n95, and now it says error, invalid http header or something.

    i deleted and reinstalled swirly, and it still had all the old settings for some reason. so im retrying the whole media net in another phone process again, but nothing seems to be working.

    any ideas?
     
  14. Knowlege Bomb macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #14
    I vote wasteland for this thread. The supposed tutorials are complete crap.

    I can't believe I wasted my time trying this for a third time. :rolleyes:
     
  15. Vonswanko macrumors regular

    Joined:
    Oct 18, 2008
    #15
    Sorry to hear its not working for you. I had to go through the steps a couple of times, but followed those steps exactly and haven't had any problems.

    Good luck
     
  16. BullittMustang thread starter macrumors 6502a

    Joined:
    Mar 27, 2008
    #16
    I also have given up. I hope Apple will include MMS in a future update.
     
  17. Warbrain macrumors 603

    Warbrain

    Joined:
    Jun 28, 2004
    Location:
    Chicago, IL
    #17
    i did nothing but enter in the details that he posted and it works fine for me. I'm able to send and receive with no issues.
     
  18. BullittMustang thread starter macrumors 6502a

    Joined:
    Mar 27, 2008
    #18
    What exactly did you enter. I will try it now.
     
  19. Warbrain macrumors 603

    Warbrain

    Joined:
    Jun 28, 2004
    Location:
    Chicago, IL
    #19
    The exact same details that the one user posted.
     
  20. dmg27 macrumors newbie

    Joined:
    Oct 29, 2008
    #20
    ok, so i tried this a little differently than below.

    First, a couple of weeks ago, i found the settings online that were as follows:
    MMSC mmsc.cingular.com
    Proxy 066.209.011.032
    apn wap.cingular
    username WAP.CINGULARGPRS.COM
    password CINGULAR1
    size: Medium
    phone: iphone

    I input these. I then called AT&T and told them that I would like to be sent the settings for MMS. The lady I talked to was an idiot and acted like (or pretended) she didn't know what i was talking about and hung up on me (ridic rude!).

    Then, I tried sending myself an MMS from my pics on the iphone and it worked miraculously. I did nothing. I was happy.

    Recently, I looked on my iphone and saw that a friend had sent me a pic (there was a little "1" on the swirly MMS program). Well, I went to try to see and it turns out the program just quits. It looks like it's "fetching message" and then just goes back to the main screen.

    So, I did what you said (below), but I wanted to make sure it was going to work. Therefore, instead of going to the website, I actually called AT&T after putting my SIM on my previous phone (LG Shine). So, with the Shine, I sent myself a picture, the AT&T folks sent me a picture, and everything was fine. I asked specifically if it would conflict with any iphone features once i put my SIM back on the iphone, they said no (but didn't sound like they knew much). I asked specifically if there was something that would cause the MMS feature to be blocked when I used the iphone, they said no.

    I put the SIM card back on the iphone, put the settings you said instead (below), and it DIDN'T WORK! When it's not saying "you don't have an active GPRA/EDGE/3G connection for the moment... (even though all bars are up and it says "3G" on top)" it's saying "unexpected http response..."

    It is ridiculous how much time I've spent on this. I have only 3 days left on my demo license, and i would have been more than willing to pay the $8 or whatever for the feature, but it's just not worth it if it's going to be this hard.

    Help. Anyone!

     
  21. dmg27 macrumors newbie

    Joined:
    Oct 29, 2008
  22. xsecretfiles macrumors 6502

    Joined:
    Aug 1, 2008
    #22

    Again if you really really want MMS, just do what I did
    I can guarantee it will work
     
  23. WillJV macrumors newbie

    Joined:
    Aug 22, 2008
    #23
    It sounded like a pretty resonable work-around yet for me everything went as described until the part where i have to send an MMS from the other phone (not the iphone) Its been past 15 mins and i'm still unable to send MMS from the non-iphone phone, but thanks for sharing this with us anyhow! it was worth a try.
     
  24. DN7335 macrumors 6502

    Joined:
    Jun 9, 2008
    #24
    The process described here works, but the problem is that AT&T performs sweeps on their network and reverses what you did. So, you'd have to do this process over and over again, and who wants to go through all that? I followed the process precisely and all worked as advertised (though it took longer than 10 minutes to be able to send an MMS). It worked great for a few hours, then I was right back to where I started from. Wasted $8 on Swirly too...
     
  25. wyseguy79 macrumors newbie

    Joined:
    Nov 8, 2008
    #25
    I was able to make my 3G iphone work with this work around along with swirly.

    I have a personal phone account, I am not on a family plan. I did manage to drop my Iphone text messaging and add the Standard messaging plan.

    I do believe that is the key to making my Iphone work. The way I tested it was by using my old Treo 750 and the SIM card from my Iphone. I would place my Iphone SIM card in the treo and send a MMS... It would tell me that my phone did not have the access to send MMS.

    After vising the medianet web site and modifying my account via the att.com web site, my Iphone was able to send and receive MMS.

    So far after 24 hours of use I have noticed that Verizon cell phone users are not receiving my MMS, but ATT & Tmobile customers are.

    Does anyone know the frequency of the sweeps? I want to see how long mine will last working.
     

Share This Page