Switched carrier now can't get data/internet

Discussion in 'iPhone Tips, Help and Troubleshooting' started by justjax, Oct 26, 2013.

  1. justjax macrumors regular

    Joined:
    Nov 15, 2011
    #1
    Okay, so I have the iPhone 5 and I just switched from Vodafone to EE.(both UK mobile networks). The voice/phone calls part is working fine but if I try and connect to a webpage I get the following message "Could not activate data network" and underneath that it says "you are not subscribed to a data service". Now I wasn't sure if I did the unlock process correctly as it was originally locked to Vodafone, but I think I did as mentioned above I can do voice calls.

    Anyway, after a reboot and resetting all networks settings I tried a restore again and this time as a new phone. That worked and I got data working, but then I went back and did a restore from back up and its gone again. Clearly something in the backup is not set up correctly for EE.

    So what to do? I'm not prepared to set it up as a new phone and loose all the stuff in my back up (mainly texts which I want), would a restore but from iCloud perhaps help?
     
  2. justjax thread starter macrumors regular

    Joined:
    Nov 15, 2011
    #2
    No one got any advice? Tried restore and then restored back up from iCloud and still no luck. EE suggested resetting all network setting and did that again as I'd already tried it. Still no luck. Anyone?
     
  3. justjax thread starter macrumors regular

    Joined:
    Nov 15, 2011
    #3
    Fixed it. If someone is having a similar issue, I went to iPhone APN changer website unlockit.co.nz and when I selected the option to send the correct APN setting and when I clicked to do it, it said to delete the current profile first, so I went into settings it was already open in that area and I could see my old Vodafone WAP certificate/profile. Deleted that and rebooted and it worked.
     

Share This Page