Switching carriers - iMessage number choice doesnt work?

Discussion in 'iOS 9' started by cameronjpu, Sep 27, 2015.

  1. cameronjpu macrumors 65816

    Joined:
    Aug 24, 2007
    #1
    So I am testing out a new carrier, which means I have a temporary phone number in my 6S. I still have the 6 with the ATT SIM. In the new phone, in iMessage settings, "start new convos from" lists both numbers and my apple ID email. I have checked my 'real' number as where new convos should start from. All options are checked in the "you can be reached at" area. yet, no matter what I do, i can't start a convo from my real number. If I check my real number, messages go out from my email address. If I select my temp number, it goes out from there. Am I trying to do something that's impossible? I have a Mac also, from which i AM able to start a new convo from my real number. Thanks for any tips!
     
  2. Falcon16 macrumors member

    Falcon16

    Joined:
    Sep 26, 2015
    #2
    try force restarting your phone and possibly resetting your network settings as a first step. if that doesn't work I'd go reset of all settings maybe something got glitched up. Last if none of those work factory restore the new phone in iTunes and see if a fresh install of 9.0.1 will help. Honestly if it's only happening on the temp number with the new carrier I'd also check for a carrier settings update could be related to the carrier somehow to
     
  3. cameronjpu thread starter macrumors 65816

    Joined:
    Aug 24, 2007
    #3
    Oh man I can't believe this fixed it. I knew it was going to work after it rebooted and i went into iMessage and settings and it reflected the fact that it was set to use my email instead of incorrectly saying it was going to use my real phone. I Changed the setting one last time and tested it, and finally it's using my real phone number. Thanks!
     
  4. Falcon16 macrumors member

    Falcon16

    Joined:
    Sep 26, 2015

Share This Page