Switching off IPv6

Discussion in 'macOS' started by Xde, Apr 23, 2017.

  1. Xde macrumors member

    Xde

    Joined:
    Jul 11, 2016
    #1
    Hello,
    usually system preferences has no ability to switch IPv6 off.

    With terminal it is possible using
    networksetup -setv6off Ethernet
    and/or
    networksetup -setv6off Wi-Fi

    Now, in network system preferences in TCPIP there is an OFF selector in the pulldown menu.

    But when one makes changes later in network setup, the selector changes back to normal ON state
    and wipes the off option again.
    Is there a way, to get this OFF option permanent?

    Remark: some system services may need IPv6

    Edit: 10.9.5 here
     
  2. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #2
    I am not sure I understand. IPv6 is not permanently disabled?
     
  3. Xde thread starter macrumors member

    Xde

    Joined:
    Jul 11, 2016
    #3
    IPv6 is always enabled. Usually you have automatic in the selector.
    Check system prefs, Network, TCP/IP.
    Terminal can set it OFF, but the "new" pull down menu selector is not permanent once you make changes.
     
  4. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #4
    I know that you can turn it off, I did not understand your particular problem. Yes, the GUI has no option to turn it off. I assume that this is intentional. Why do you want to turn it off in the first place?
     
  5. Xde thread starter macrumors member

    Xde

    Joined:
    Jul 11, 2016
    #5
    OK, I have a network problem here, Router and Rasperry Pihole.
    Maybe the router is something to do with that. Its not a specially good one.
    I tried to disable v6 and voila problem was gone.
    Me question was only, if there is a way to permanently enable the "off"-option in the menu.
    Probably not.
     
  6. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #6
    It does not look like it. If you do need to tweak the settings frequently, I recommend you set up a new ‘location’ in the network settings. You can have completely separate network settings and switch between these profiles on-demand.
     
  7. Xde thread starter macrumors member

    Xde

    Joined:
    Jul 11, 2016
    #7
    Ok, thank you Kallt.
    I am still in work with the problems on the Router and Pihole side.
    I would prefer to not change the standard settings, hope to get it running soon...
     
  8. Yahooligan macrumors 6502a

    Yahooligan

    Joined:
    Aug 7, 2011
    Location:
    Illinois
    #8
    "Link-local" is about as close as you're going to get, which will limit IPv6 to the local network. Have you tried that to see if the problem goes away?
     
  9. Xde thread starter macrumors member

    Xde

    Joined:
    Jul 11, 2016
    #9
    O, thanks for the information! I haven't seen your reply.
    I changed the IPv6 setting back to normal, to not break any OS inside service.
    And I solved the problem within the router.
    My DHCP router has an IPv6 local "ULA" setting. Unique Local Addresses
    I transferred the Ip address to the Pihole and the problem was gone.
    Thanks anyway...
     

Share This Page