Switching SIM...a profoundly bad move!!

macmadandproud

macrumors member
Original poster
May 16, 2006
51
0
So here is my story, and I am sticking to it! Let me know if anyone else has experienced the same thing...

I wanted to go out one night with a smaller phone, so I put my iPhone SIM into my w810i. I realized the my vm would not be set up so I set it up on the w810. Things were fine until I put the SIM card back into the iPhone. As odd as this sounds, my e-mail no longer came in. I could browse the web fine, and could see all of my old gmail, but nothing new came into my mailbox.

I did what any good god-fearing iPhone owner would... I freaked! Upon restoring my iPhone things were back to normal; or so I thought! As soon as I re-setup my visual voicemail, mail no longer came in. I spent hours on the phone with Apple, AT&T, and even my hot stone masseuse trying to find a solution to the problem.

I went to Apple, who quickly gave me a new phone, saying with certitude that it would surely fix my problem... but to no avail! This morning I went to AT&T and put a new SIM in, it seems the old one was corrupt, but still my e-mail would not flow. Only after yet another restore, do things now seem to be back to normal.

sorry for the long garrulous tale, but I suppose the moral of the story is... don't put your iPhone SIM into your old AT&T phone unless you have a few hours to spend dealing with the consequences!!

Am I the only one who has taken such a journey? Am I the only one who is having a hard time seeing a connection between visual voicemail and the flow of e-mail...well, aside from their both having 'mail' in their names!
 

apfhex

macrumors 68030
Aug 8, 2006
2,670
4
Northern California
I see no connection either. Very odd. Shouldn't be any reason not to use your SIM in another phone, has nothing to do with email, at least you would think.