Switching wireless networks OS X asking for password

Discussion in 'macOS' started by netnothing, Jun 28, 2008.

  1. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #1
    At my Moms house, she has a Linksys wireless router setup to serve b/g traffic, and a Time Capsule setup to serve n traffic.

    For some reason, when I go to switch to use one or the other, OS X prompts me to enter her user password. This is the account password, not the WPA password (that is stored in the Keychain).

    Her user is an admin user.

    Any idea why the system asks everytime I select either of the networks for the account password?

    -Kevin
     
  2. italiano40 macrumors 65816

    italiano40

    Joined:
    Oct 7, 2007
    Location:
    NY
    #2
    system prefrences>Network>airport>advanced>Uncheck "Require Administer Password to control airport
     
  3. Mlobo01 macrumors 6502

    Joined:
    Jan 23, 2003
    Location:
    Weehawken New Jersey
    #3
    check the settings...

    In System preferences, under Network you either must deselect "connect automatically to a network" or you must choose a different "location" when selecting a differenet network that has the password and settings already registered? see if this works. Another hint is to check to see if the second account is an admin acct or a standard acct. This maybe causing this prompt.
     
  4. netnothing thread starter macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #4
    Nope, doesn't change it.

    I think I tried this at one point.

    All I'm doing is going to the Airport Menu in the menubar, and selecting either the G or N network. Just changing either of these, requires the system to ask for the user account password.

    -Kevin
     
  5. netnothing thread starter macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #5
    So, both of the networks are listed in the System Preferences as networks to join automatically.

    The thing is, she doesn't get asked for a password any other time (like bringing the system out of sleep...or a restart). It's only when I manually select the other network.

    I have the same setup as my Mom....same routers, same MacBook, and mine never asks if I manually switch them.

    What preferences files might be corrupt? I think something is not allowing the system to automatically use the entries in keychain.

    When I look at the details of the password box, it lists:

    Right: com.apple.airport
    Application: SystemUIServer

    How come I can't find the com.apple.airport file on the system?

    -Kevin
     
  6. netnothing thread starter macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #6
    I created a new admin user and the same thing happens.

    Any other clues anyone?

    Is there a pref file I should be looking at removing and see if that helps?

    -Kevin
     
  7. netnothing thread starter macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #7
    Also posted on the Apple discussions.

    Well, it looks like the Require Admin password to control Airport was the culprit.

    Seems though that this option requires the user to either restart, or log out and back in for it to take effect. That's why it wasn't working for me during testing.

    Also, seems MY laptop had the corrupt preference file somewhere, as I had that option checked, but it wasn't requiring my password. After I unchecked it, and rechecked it, and logged out, it's working correctly.

    Thanks for the help.

    -Kevin
     

Share This Page