Symbolic Links work differently?

Discussion in 'OS X Mountain Lion (10.8)' started by orbitalpunk, Jul 26, 2012.

  1. orbitalpunk macrumors 6502

    orbitalpunk

    Joined:
    Aug 14, 2006
    #1
    Hi there,

    I use symbolic links to link my mail, calendar and address book onto another volume thats backed up. This has worked in every version of OSX since Tiger. But for some reason, its partially not working for Address Book in Mountain Lion. Here's the issue, I symlink my AddressBook folder under Application Support onto another Volume. I open Address Book and all my contacts are there. It works as always, but when I use Mail, it can't find my address book contacts and so auto complete is not working in the To: dialog box when composing a new message. And when I click on addresses in mail, its empty. It works perfectly when not symlinking my address book so its not my AddressBook archive being the problem.

    Anyone have similar issues or know how to fix this?

    My method for creating the symlink in terminal is this:

    cd /Users/User/Library/Application\ Support
    ln -s /Volumes/HardDrive1/AddressBook AddressBook

    Thanks for any help
     
  2. sexiewasd macrumors regular

    Joined:
    Mar 14, 2012
    Location:
    Back in Your Head
    #2
    My symlinks are working fine. I run deep freeze by faronics, and I move my document, pictures, music ect... folders onto the thawed partition and leave symlinks in their place.

    I use this to make my symlinks with, http://www.macupdate.com/app/mac/10433/symboliclinker/
     
  3. orbitalpunk thread starter macrumors 6502

    orbitalpunk

    Joined:
    Aug 14, 2006
    #3
    yeah, my documents and pictures work fine. Its just when mail tries to access a symlinked addressbook folder. This is happening on 2 computers both fresh installs.

    Now I am think about linking my entire user folder instead to another drive under the accounts advanced option.
     
  4. Gafuliz macrumors newbie

    Joined:
    Aug 1, 2012
    #4
    Same here

    Hi Community, hi orbitalpunk,

    i can confirm that problem. In get it also in another workaround. I use MAMP to run an apache, php and mysql server. In Snow Leopard i had stored my mysql data in my user folder (~/.../) with a symlink out of the application folder. In 10.8 this link seems to be broken too.

    Are there any statements on the part of apple?

    Thanks for help!
     
  5. vonkas macrumors newbie

    Joined:
    Dec 23, 2003
    #5
    Symbolic links in Mountain Lion 10.8 are broken! I use Dropbox to sync my bookmarks. In 10.8 as soon as you alter the bookmarks, the sym-link gets replaced by a plist.
     

Share This Page