Sync bug iphone 3.1 -> Addressbook 5.0.2 (MacOS 10.6.4)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Dwertenb, Oct 23, 2010.

  1. Dwertenb macrumors newbie

    Joined:
    Jun 13, 2010
    #1
    Address Book stopped syncing both ways (phone to Mac and Mac to phone), everything else syncs smooth. Running out of ideas

    Tried resetting isync history, unchecking "All Contacts" to Selected Groups and re-checking back and forth, reading tons of threads, no solution yet.

    Wiping out database on my iphone is not an option: I just realized the bug today. I don't know since how long it's not syncing anymore, thus I will loose all the data I entered and modified on the phone since whenever the sync broke.

    Any tool/help to inspect the delta of the database on the phone and the Mac? (like "diff") ?

    Phone is jailbroken.

    Thanks for any hint!!!
     
  2. Dwertenb thread starter macrumors newbie

    Joined:
    Jun 13, 2010
    #2
    One step closer... ...but not fixed (yet)

    It's not an iPhone problem. It's between AddressBook and iTunes.

    #1 Connecting another iPod shows the same limited contact groups (3 out of 20)
    #2 I tampered with the Library folder: Quote from another thread "... i knew the issue wasnt with address book, but isync, so went into the sync services folder under app support (NOT the main one in the library folder) and replaced that with a fresh copy from another user account, i fixed the permissions on the file and voila, contacts synced!"

    I see in iTunes clicking on my iPhone device and "Info" Tab, the Contacts folder is now completely empty, no more groups at all.

    I guess the problem is related to the sync of AddressBook and ITunes.

    Any thoughts?
     
  3. Dwertenb thread starter macrumors newbie

    Joined:
    Jun 13, 2010
    #3
    pretty boring monolog here... ...I'm missing these times people took time helping others.

    Anyway, I solved it. In case you stumble over the same problem, I quickly write down what I did to help you:

    Problem was a corrupt database of Address Book. I exported the original Address Book and started from scratch building a new one copying group by group into the new one until it broke again. Isolated the wrong group. Exported it, deleted it and imported it again. Worked fine. Everything syncs again. :)
     

Share This Page