Sync Gmail calendar with iCloud?

Discussion in 'iOS 5 and earlier' started by filmbuff, Oct 13, 2011.

  1. filmbuff macrumors 6502a


    Jan 5, 2011
    I have gmail set as my default calendar in the calendar app on my iPad. Everything I enter automatically syncs with my gmail calendar online. I also set calendars to "on" in the iCloud settings. However, when I go to and click calendars, none of my events show up. The only calendars available are the default "home" and "work" ones for iCloud. Is there a way to get my gmail calendar events to show up on

    While I'm posting, can I get the mail button to show all of my accounts instead of just the account?

    EDIT: I have a PC running Windows 7 if that matters.
  2. rwilliams macrumors 68040


    Apr 8, 2009
    Raleigh, NC
    In Settings -> Mail, Calendar & Contacts, turn off the calendar for your Gmail account. It should ask you if you want to keep or delete all of your calendar events for that account. Choose to keep them so that you have a local copy of your calendar on your iPad. Then, go to the iCloud settings on your iPad, turn off the calendar, and then turn it back on. It should then sync your local calendar to iCloud.

Share This Page