Sync iPhone Messages and iMessage on MacBook

Christopher11

macrumors regular
Original poster
Feb 10, 2007
224
6
I got kicked out of Messages on my MBpro for some reason, and after logging in, they are no longer synced. I don't mean Messages missed a few; that's no problem, I mean that they no longer show the same content. I can send a text from Messages and not see it on my iPhone, yet the receiver tells me they got it. Is there a way to set this so they sync up again? It is ios12 and El Capitan. Thank you for any reply.
 

Ruggy

macrumors 6502
Jan 11, 2017
251
154
I'm not on El Capitan any more so this might not be relevant I'm afraid but there are two ways to force sync that I know of:
1. Quit the app and restart.
2. Go into iMessage preferences> @> sync now.
They do get slightly out of synch sometimes and I just Quit and restart as it's quicker.
Hope that helps.
 

Christopher11

macrumors regular
Original poster
Feb 10, 2007
224
6
Thank you but in Messages > Preferences I don't see anything with the option to sync now.
 

Christopher11

macrumors regular
Original poster
Feb 10, 2007
224
6
Hey there. Any other ideas from you talented folks? It is incredibly convenient and helpful for me to be able to type texts when I'm at my MacBook. I've gotten used to it. Thank you in advance for any suggestions.