sync with google calendar not working

Discussion in 'iOS 6' started by ghanwani, Oct 22, 2014.

  1. ghanwani macrumors 6502a

    Joined:
    Dec 8, 2008
    #1
    I'm trying to help a friend with his phone. It's a 4S running iOS 6.1.3.

    He uses a bunch of google calendars (his own plus a few others), and google calendar is configured to share entries between them.

    He's having trouble with his phone -- entries he creates in google calendar or on the phone don't show up in the other place.

    What can be done? He has already tried deleting all of the accounts and then adding them.

    I was think of deleting all the accounts and adding/debugging one at a time.

    Has anyone else faced this problem? Any advice to offer with how to debug this setup?

    Is there any reason why he needs to add multiple accounts to the phone if he already has sharing setup between the accounts?
     
  2. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    If he has the proper permissions ("Make Changes") from the owners of the other Google calendars to his own Google account and he has entered his account on the iPhone as a Google account, then he should be able to add events to them.

    Otherwise, you probably need to describe the situation better. I'm not sure why, if the above is true, he would be adding more than one account to the iPhone.
     
  3. ghanwani thread starter macrumors 6502a

    Joined:
    Dec 8, 2008
    #3
    Indeed I don't understand why he has things set up that way. I'm planning to spend some more time with him to try and address this on Saturday.

    But even in the absence of multiple accounts, even with just a single account of his own, he's not able to get things to sync correctly.
     
  4. Arynaria macrumors newbie

    Joined:
    Nov 16, 2014
    #4
    I figured this out for my own sync issues after a lot of headaches. No restores, resetting, or multiple accounts needed.

    First, make sure he has the calendars he wants checked off on Google's mobile sync page. Also check to see that the iPhone has access to Google in the first place.

    Now, I could be wrong, but you/he probably tried setting this up via Exchange originally. If so, that's part 1 of the problem. Exchange is just too buggy with Google now. Luckily, the actual Google account option is finally working.

    Note: This was tested on an iPhone 6 with iOS 8.1, but it will probably work for earlier iOS versions, since the actual settings menus haven't changed too much.

    1. Set up your account through Google (not Exchange) and make sure "Calendars" is turned on.
    2. Go to "Mail, Contacts, Calendars", and you'll see an option for "Fetch New Data" under your accounts.
    3. Open "Fetch New Data". At the bottom there is an option called "FETCH", which gives a little blurb about the schedule and battery life. It will likely be set to "Manually".
    4. Change the setting from "Manually" to "Hourly".
    5. Go to the "Default Calendar" screen at the very bottom of "Mail, Contacts, Calendars". You should now see all your custom calendars as choices.
    6. Once you select your new default, all calendar apps should be able to access the data and sync like they did before with Exchange. Adding/editing/deleting events also works fine from both the phone or the web.
    I have recreated the "problem" and fixed it this way multiple times. I don't know if it's considered a workaround or not, but my calendar sync issues are 100% gone. Good luck with it on the older phone!
     
  5. ghanwani thread starter macrumors 6502a

    Joined:
    Dec 8, 2008
    #5
    Thanks.

    I'm trying to follow these instructions right now and I do not see his email account (even though it has Calendar turned on) under "Default Calendars."

    Any idea what's going on? I tried googling around but don't come up with anything useful.

    He already has another gmail account which does show up on the phone under Default Calendars. Could it be that Gmail/Google does not want to have more than one calendar on the phone, expecting that sync between multiple accounts should happen via Google rather than directly to the phone?
     
  6. ghanwani thread starter macrumors 6502a

    Joined:
    Dec 8, 2008
    #6
    I finally got this to work.

    There were several problems.

    First, the calendar was not showing under Default Calendars because google accounts must be setup under CalDav for iOS 6.

    Second, google does not like folks logging in from iOS 6 so it blocks those. You have to enable "less secure" access to the account in order for the login from CalDav to work.

    Third, because he has multiple gmail accounts and we were switching between them on the same computer, google did not like that and was logging us out.

    Anyway, for now everything seems to be working OK.
     
  7. Arynaria macrumors newbie

    Joined:
    Nov 16, 2014
    #7
    Strange. I didn't run into any of those problems, even on earlier iOS versions and phones.

    1) I never needed to use CalDav. I just went through Mail, Contacts, Calendars --> Add Account --> Google for all of my accounts. I previously went through Exchange since the Google option was broken (plus it didn't support Push), but now Exchange doesn't function properly for people while Google finally does. It may not have Push, but Hourly Fetch is better than nothing.

    2) I've never had to block or make anything "less secure". Even on the Google/web end of things. The accounts I use are locked down pretty well - 2-factor authentication, app passwords (which I did use for this, incidentally), etc.

    3) Regarding multiple accounts, problem there either. I have...far too many Google accounts, and I can be signed out of all of them (or signed in to more than one) on the web and it doesn't cause any error or security block. Plus in Mail, Contacts, Calendars, every account can have calenders turned on, and they all show up in Default Calendar settings and connected apps.

    I'm not sure what the problem could be for your friend. I'll mess with various options on different phones and see if I can reproduce the issue. Maybe something to do with ticking off which calendars to sync (mobile site) for each account?

    As another suggestion, have you considered sharing calendars between all of his Google accounts (giving viewing/editing privileges or subscribing)? That way he would have access to them all (he can turn them on/off as needed) no matter which account is signed in, and he would only need to use one account on the phone and avoid the whole conflict in the first place. Just a thought.
     
  8. ghanwani thread starter macrumors 6502a

    Joined:
    Dec 8, 2008
    #8
    Googling around it looks like google calendar without CalDav is broken on iOS 6. So CalDav is a must.

    I think the security thing where google doesn't accept logins from the CalDav application on iOS 6 may be new. It accepts login via GMail, just not from CalDav. Once I enabled "less secure" access it worked. And once it worked, it continued to do so after the "less secure" access was disabled.

    Yes, I too suggested to him that all the sharing between accounts should happen within google calendar, and the sync to the phone should be only via his own account. I didn't have the patience to try it and show him its working about there were too many accounts and like I mentioned google was preventing his machine from logging into them. The problem in his case is maybe while creating the accounts it has different names for the owner and so google thinks they are owned by different people.

    One day later and it all continues to be working fine. Both he and his wife keep thanking me!
     

Share This Page