Syncing iCloud with iPhone, MacBook, and iPad

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by vermilionx2, Aug 3, 2014.

  1. vermilionx2 macrumors newbie

    Joined:
    May 28, 2014
    #1
    Hi all,

    I am using the same iCloud ID for all 3 of my Apple devices but for some reason the iMessages are no longer synced. Previously i was able to continue and resume same iMessage conversation from my iPhone to Mac or iPad and vice versa. I am not sure what happened but now it seems that my cell phone number is unlinked from my Macbook and iPad so when I send iMessage on iPad or Macbook it starts a new window and shows sender as my iCloud email address instead of my phone number...

    Can someone please help? It was working fine before... Thank you

    Dave
     
  2. SpyderBite macrumors 65816

    SpyderBite

    Joined:
    Oct 4, 2011
    Location:
    Xanadu
    #2
    In the icloud settings you can add any missing phone numbers and/or email addresses. As soon as all three have exactly the same number of contact methods they should sync fine.

    However.. If you are sharing an Apple ID your going to be all kinds of mixed up all the time. :)
     
  3. vermilionx2 thread starter macrumors newbie

    Joined:
    May 28, 2014
    #3
    I have looked everywhere in iCloud settings on my iPhone and MacBook and I am unable to add my phone number to my iCloud account. Is this another iCloud setting you are referring to? Thank you
     
  4. whsbuss macrumors 68040

    whsbuss

    Joined:
    May 4, 2010
    Location:
    SE Penna.
    #4
    On your iPhone, disable messages in settings, restart, then enable it again. You should be offered the ability to add your phone number and any apple ID registered email accounts.
     
  5. Primejimbo, Aug 4, 2014
    Last edited: Aug 4, 2014

    Primejimbo macrumors 68040

    Joined:
    Aug 10, 2008
    Location:
    Around
    #5
    I had this issue yesterday and this is what I did to fix it. Look at the iPhone iMessage settings. I saw that I only had 1 number and on email addresses under the "Send & Receive" settings, and noticed it said at the top something along the lines "add you iTunes/iCloud to you iMessage" or "use your iApple ID for iMessage", I can't remember the wording, but it was at the top. I logged into my iCloud and I got a pop up on my iPad to use my cell number on it. My iMessages started to work great again on both my iPad and iPhone.

    I hope this helps.
     

Share This Page