Syncing iPhone Issue -> Forced restore?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by netdawgx, Jul 27, 2011.

  1. netdawgx macrumors newbie

    Joined:
    Jul 27, 2011
    #1
    I will try to be as clear and detailed as I can about this problem. It is not a run of the mill sync problem from my research (yes, I googled, etc. :D)

    I backed up my iPhone a very long time ago (11/8/2010).
    Since then I purchased media, took pictures, made new contacts, etc, on my iPhone. = basically lots of new data since last backup.

    When I plug my iPhone 3GS to transfer this new data into my computer (PC) I am only getting the following message with the following 2 options:
    SET UP YOUR IPHONE
    This computer has previously been synced with an iPhone or another iOS:
    Option A) Set up as a new iphone
    Option B) Restore from backup of "my iPhone 11/8/2010".

    Yes yes I know, I don't backup or sync often and I should. Moving on :p.

    The problem is this: I have new purchases (music/videos/apps) that I want to transfer onto my hard drive. I also have notes/pictures/contacts that I made since 11/8/2010 that I am sure I would lose if I restored.

    When I right click on the iPhone in iTunes it only gives me 1 option: Eject.

    So... here is what may have caused this:
    1. I Deauthorized "ALL" computers then reAuthorized this computer (same account of course). Note: This is the same computer I have always synced with, no reformat, etc.
    2. I changed the location of my iTunes media folder to a shared external network hard drive. First I copied the entire iTunes folder (database files + media + everything else) to my network hard drive and then I simply went into iTunes and changed the iTunes media path.

    So my question is this: How can I bypass this and have my iTunes recognize my iPhone thereby letting it sync, transfer purchases, contacts, etc. and create a current backup?

    Here is what I have tried so far:
    Reset the path of my iTunes media back to its original location on the local hard drive. No dice here.

    Thank you in advance for your help, it is much appreciated.

    -Abhi
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    None of that should have mattered (i.e., deauthorizing/reauthorizing and changing the media path). The only message you should get is that the iPhone was synced with another library, perhaps.

    Right click in the left pane of iTunes on the iPhone icon and make a backup. Also right click and transfer purchases.

    You should then be able to sync the phone without restoring (just ignore the message about erasing the phone, since you’ll be syncing most of it back, assuming you have this stuff on your computer).

    Edit: Just noticed you only get the eject when you right click. You may have issues there. You might need to reinstall iTunes, try another USB port, another computer, etc.
     
  3. netdawgx thread starter macrumors newbie

    Joined:
    Jul 27, 2011
    #3
    *FIXED*

    Before I tell you the fix I should warn that I did all the following:
    Uninstalled iTunes
    Restarted Computer
    Reinstalled iTunes
    Restarted Computer
    Hard Reset the iPhone (Pressing Home + Power for 10 sec)
    Tried different USB outlets.
    Backed up all my data with 3rd party software.

    Finally I bit the bullet and just hit the option "Setup a new iPhone."
    On the next screen I changed nothing (left all sync options at default).
    I hit Start.

    Magically, the software somehow fixed itself... It went straight to the iPhone settings screen. Nothing was deleted, moved or edited (pictures, contacts, notes, etc.). A sync automatically occured and my phone was backed up.

    Seriously... all is well that ends well I guess.

    Also, for those of you wondering I Googled some more before all of this and found 3 instances or so of this exact same situation happening to others. I was hoping I'd get lucky and I did. I do not know the rate of this magically working. Please backup all your data before you try.

    Lesson learned: backup constantly.

    -Thanks all.
     

Share This Page