Syncing music library to iPhone via iTunes, album art issues?

Discussion in 'Mac Basics and Help' started by alexreich, Jun 25, 2012.

  1. alexreich macrumors 6502a

    alexreich

    Joined:
    Jan 26, 2011
    #1
    Last night, I left my iPhone plugged into my G5 overnight to sync about 900 songs (I had to let it go overnight because my library is in Apple Lossless format, and my G5 has to downgrade the files into a lossy-AAC format, and this is hard on the old CPU).

    No worries, all songs are there. But, album artwork on these albums/songs is patchy throughout my iPhones library? All of my imported CDs and iTunes purchases have the correct album artwork in iTunes on my computer, but my iPhones library is spotty. Some albums have art, others don't.

    I've tried just deleting one album that doesn't have artwork, and then re-syncing it in iTunes, but even after reloading the media there isn't any artwork.

    Any ideas?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Have you verified that all songs in all albums have album art? iTunes will show the album art of the first track in the album that has it. So if you have 12 tracks in one album, each with their own different artwork, the art that is displayed for the album will the the art used on Track 1. If Track 1 has no art, it will use the art from the next track that does. When you sync into your iPhone, the Music app uses the art stored in each particular song. So if you have an album in iTunes with artwork only on Track 1 and none on the other tracks, it will show up fine in iTunes, but on your iPhone, the tracks without artwork will show none.
     
  3. alexreich thread starter macrumors 6502a

    alexreich

    Joined:
    Jan 26, 2011
    #3
    I have had an issue in the past with my albums only having the first song containing artwork, but I thought I fixed that issue, as I am pretty much a perfectionist when comes to my media (all songs must have all info filled out+artwork, all my movies must have info filled out+artwork, I have lossless and lossy versions of all my music).

    I'm going to clear artwork on my library, and re-download the artwork for everything, and sync again. Maybe that'll fix it.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    Doug's AppleScripts for iTunes is a great resource for managing your iTunes tags and files. This script may help:
     
  5. alexreich thread starter macrumors 6502a

    alexreich

    Joined:
    Jan 26, 2011
    #5
    Thank you for that link. About to try it out now and see if I can find anything.

    ----------

    All of my songs in every album have artwork, according to the AppleScript I used from that guy's site. Crazy.

    I used the 'Albums without Artwork' script which outputs all albums that have songs with missing artwork into a text file. When the file was generated, there were no contents in the file.

    I just wiped all of the music off my iPhone, and I've loaded a few albums one by one, and the artwork is showing fine... I have no clue why when I loaded my complete library I had issues.
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    That's strange. I don't have that problem, as I can't fit my library on an iPhone, anyway. I've had a tough time trying to get my favorite songs trimmed down so they'll fit!
     
  7. alexreich thread starter macrumors 6502a

    alexreich

    Joined:
    Jan 26, 2011
    #7
    I have 933 songs. Haha. And while in lossless they exceed my iPhone's capacity by a large amount, I have my iTunes preferences set to downgrade the audio files to 256kbps AAC before syncing them to my iPhone so I can fit them all. :)
     

Share This Page