System animations lagging/appear choppy

Discussion in 'OS X Mavericks (10.9)' started by ideal.dreams, Dec 20, 2013.

  1. ideal.dreams macrumors 68020

    ideal.dreams

    Joined:
    Jul 19, 2010
    Location:
    OH
    #1
    I'm using the latest version of Mavericks on the Retina MacBook Pro in my signature. I noticed that since playing Minecraft for the first time since I upgraded to Mavericks, some of the animations are lagging and seem choppy. I notice this most when using Mission Control - when the windows kind of zoom out to display all of the open apps it's not smooth and fluid, but rather choppy. I've restarted my MacBook since I noticed the issue but that doesn't seem to have resolved anything.

    Can anyone shed some light on this?
     
  2. cbs20 macrumors member

    Joined:
    Feb 26, 2013
  3. ideal.dreams thread starter macrumors 68020

    ideal.dreams

    Joined:
    Jul 19, 2010
    Location:
    OH
    #3
    I've reset the SMC however it did not fix the issue.
     
  4. ideal.dreams thread starter macrumors 68020

    ideal.dreams

    Joined:
    Jul 19, 2010
    Location:
    OH
    #4
    I called Apple regarding this issue and spent 30 minutes on the phone with an advisor and was ultimately told by the end of our conversation that the only way to fix the issue at this point would be to reinstall the OS. I am definitely not doing that as I simply don't have the time do deal with the amount of effort that requires.

    Some things we tried:
    -Resetting SMC
    -Resetting PRAM
    -Using Disk Utility to: Verify and repair disk, verify and repair disk permissions

    If ANYONE has any other ideas, I'm all ears!
     
  5. sshhoott macrumors 6502

    sshhoott

    Joined:
    Feb 6, 2010
    #5
    Is this a first generation 15" rMBP? If it is, it's probably running on an Intel HD 4000 when you get the choppy animations. To be quite honest, Intel HD 4000 is crap and doesn't belong in the 15" rMBP (thats why they made a HUGE upgrade to the Intel graphics in this year's model). Use the Nvidia card, it is much more powerful and will be able to handle all animations with ease.

    Try disabling the "automatic graphics switching" option in Energy Saver system preferences: http://support.apple.com/kb/ht4110. This will always keep the powerful Nvidia card enabled.

    Give it a restart and animations should be back to super smooth. If they aren't, it would mean that it's not the Intel HD 4000 graphics but just the bad installation of your OS X Mavericks. You're gonna have to clean install it.
     
  6. ideal.dreams thread starter macrumors 68020

    ideal.dreams

    Joined:
    Jul 19, 2010
    Location:
    OH
    #6
    Yes it is a first generation rMBP. I disabled the automatic graphics switching and rebooted my computer however it seems to have made no difference. I reinstalled Mavericks through the recovery partition but it wasn't clean install. I've tried everything but a clean install at this point and it's not even worth it for me anymore. I can live with the laggy animations - there's no way I have the time to put back everything the way it is now.

    The funny thing is, this wasn't ever an issue, even on Mavericks (originally). I have no clue what caused it to be like this.
     
  7. sshhoott macrumors 6502

    sshhoott

    Joined:
    Feb 6, 2010
    #7
    It's something running in the background that's causing this. That was perhaps introduced to your Mac near the time when you started playing Minecraft. Open up the Activity monitor and check for any abnormal CPU usage and also check your memory and disk usage when your Macbook is idle.

    Another possibility is that OS X 10.9.1 update introduced this problem (the update was released on December 16, 2013). Did you start noticing this problem after you updated to OS X 10.9.1?
     
  8. TallGuyGT macrumors regular

    TallGuyGT

    Joined:
    Aug 8, 2011
  9. ideal.dreams thread starter macrumors 68020

    ideal.dreams

    Joined:
    Jul 19, 2010
    Location:
    OH
    #9
    That very well could be the issue, the 16th sounds about right when I started noticing this issue. I checked out Activity Monitor and CPU-wise, the top thing on the list is "WindoServer" and it fluctuates between 5-12%, which actually does seem quite a bit high. Memory-wise, kernel_task, WindowServer, and com.Apple.iconservicesagent are at the top of the list, with kernel_task using 600+ MB, WindowServer using 76 MB and the com.Apple one using 62 MB.
     
  10. sshhoott macrumors 6502

    sshhoott

    Joined:
    Feb 6, 2010
    #10
    Those numbers seem fine. Although the window server CPU usage is a couple points higher than mine, it shouldn't really make a difference in animations. All the memory usage is fine, mine is the same.

    I think it's most probably a bug in OS X 10.9.1 itself OR your upgrade to OS X 10.9.1 was interrupted in some way. Try reinstalling the update by downloading this installer from Apple's website (it doesn't delete any settings or data, pretty minor update). But remember to close all running and background apps before you run the update:

    http://support.apple.com/kb/DL1715


    If reinstalling didn't fix this issue, report the problem to Apple in detail along with your machine model/specs:

    http://www.apple.com/feedback/macosx.html

    Good Luck!
     
  11. ideal.dreams thread starter macrumors 68020

    ideal.dreams

    Joined:
    Jul 19, 2010
    Location:
    OH
    #11
    I just finished reinstalling 10.9.1 and that didn't help the issue. I guess I'll wait for Apple to release 10.9.2 and hope that fixes the issue. Thanks for all of your help!
     
  12. sshhoott macrumors 6502

    sshhoott

    Joined:
    Feb 6, 2010
    #12
    Hopefully they fix it but also send them the feedback. Cheers.
     
  13. ideal.dreams thread starter macrumors 68020

    ideal.dreams

    Joined:
    Jul 19, 2010
    Location:
    OH
    #13
    THIS IS NOT AN ISSUE WITH 10.9.1!!

    A senior advisor with Apple called me after escalating this issue to their software engineers and by looking at a capture of my OS, they replicated this issue after installing "DisplayLink" software. I uninstalled it and this issue is now resolved.
     

Share This Page