"System extension cannot be used" problem in SL

Discussion in 'macOS' started by nobblynoel, Sep 12, 2009.

  1. nobblynoel macrumors member

    Joined:
    Sep 11, 2009
    #1
    Hi all,
    First post but been around for 6 months.
    Installed Sl Fresh install But get this message from time to time. Came again this morning when updated apple Canon printed drivers. Also have Canon scanner LIDE60. So I have a feeling its a canon problem??
    [​IMG]
     
  2. electroshock macrumors 6502a

    electroshock

    Joined:
    Sep 7, 2009
    #2
    Yup, looks like. Not sure which is newer: the version Apple offered or the one Canon offered three days ago, but if you want to try Canon's installer:

    If you're in the USA, go to:

    http://usa.canon.com
    Enter 'Lide 60' in the search box and click on 'Search'
    Click on 'Drivers and Downloads'
    Click on the 'Select OS' menu drop-down and select MacOS X
    Click on the DMG link in the Drivers section
    Click on 'I Agree - Begin Download' button at bottom of the page

    Canon's page says this version is compatible with Snow Leopard. So it's worth a try, especially since it's possible Apple's distributed a slightly older version.
     
  3. nobblynoel thread starter macrumors member

    Joined:
    Sep 11, 2009
    #3
    thanks electroshock
    I was taking the lastest driver from the uk canon site it was a 10.5 driver. They haven't updated to the Sl driver yet. USA1 UK 0
    I will try it
    thanks
     
  4. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #4
    I did a clean install w/o any printer drivers.
    Downloaded the current OSX printer drivers from canon
    Moved the installation program to my desktop
    Right clicked the installation program and selected show package contents
    Navigated to Contents/Resources
    Deleted the InstallationCheck file
    Installed the drivers.


    I tried doing this w/o a clean install and also installing the OSX drivers and then trying to install the canon drivers. That didn't work. For me not having any printer drivers installed in SL was the first requirement.

    Canon has also stated a new updated set of drivers is due either in late September or October (I forget exactly) so you can also wait for them as well.
     
  5. nobblynoel thread starter macrumors member

    Joined:
    Sep 11, 2009
    #5
    maflynn did you update the canon drivers from apple which came out today.
    I did this from SL software update ?
     

Share This Page